Fix some bugs when testing opensds ansible
[stor4nfv.git] / src / ceph / debian / radosgw.postinst
1 #!/bin/sh
2 # vim: set noet ts=8:
3 # postinst script for radosgw
4 #
5 # see: dh_installdeb(1)
6
7 set -e
8
9 # summary of how this script can be called:
10 #
11 #       postinst configure <most-recently-configured-version>
12 #       old-postinst abort-upgrade <new-version>
13 #       conflictor's-postinst abort-remove in-favour <package> <new-version>
14 #       postinst abort-remove
15 #       deconfigured's-postinst abort-deconfigure in-favour <failed-install-package> <version> [<removing conflicting-package> <version>]
16 #
17 # The current action is to simply remove the mistakenly-added
18 # /etc/init/ceph.conf file; this could be done in any of these cases,
19 # although technically it will leave the system in a different state
20 # than the original install that included that file.  So instead we
21 # only remove on "configure", since that's the only time we know we're
22 # successful in installing a newer package than the erroneous version.
23
24 # for details, see http://www.debian.org/doc/debian-policy/ or
25 # the debian-policy package
26
27 [ -f "/etc/default/ceph" ] && . /etc/default/ceph
28 [ -z "$SERVER_USER" ] && SERVER_USER=ceph
29 [ -z "$SERVER_GROUP" ] && SERVER_GROUP=ceph
30
31 case "$1" in
32     configure)
33         [ -x /sbin/start ] && start radosgw-all || :
34
35         if ! dpkg-statoverride --list /var/lib/ceph/radosgw >/dev/null
36         then
37             chown $SERVER_USER:$SERVER_GROUP /var/lib/ceph/radosgw
38         fi
39     ;;
40     abort-upgrade|abort-remove|abort-deconfigure)
41         :
42     ;;
43
44     *)
45         echo "postinst called with unknown argument \`$1'" >&2
46         exit 1
47     ;;
48 esac
49
50 # dh_installdeb will replace this with shell code automatically
51 # generated by other debhelper scripts.
52
53 #DEBHELPER#
54
55 exit 0
56
57