OVSNFV-42: Fix incorrect license for specs file
[ovsnfv.git] / build / patches / ovs_nsh_patches / openvswitch-kmod.spec
1 # Generated automatically -- do not modify!    -*- buffer-read-only: t -*-
2 # Spec file for Open vSwitch.
3
4 # Copyright (C) 2009, 2010, 2015 Nicira Networks, Inc.
5 #
6 # Copying and distribution of this file, with or without modification,
7 # are permitted in any medium without royalty provided the copyright
8 # notice and this notice are preserved.  This file is offered as-is,
9 # without warranty of any kind.
10
11 %global debug_package %{nil}
12
13 #%define kernel 3.1.5-1.fc16.x86_64
14 #define kernel %{kernel_source}
15 %{?kversion:%define kernel %kversion}
16
17 %define ver 2.5.90
18 %define rel 1
19 %define snapver 11975.NSH7d433ae5
20
21 %define srcver %{ver}%{?snapver:-%{snapver}}
22
23 Name: openvswitch-kmod
24 Summary: Open vSwitch Kernel Modules
25 Group: System Environment/Daemons
26 URL: http://www.openvswitch.org/
27 Vendor: OpenSource Security Ralf Spenneberg <ralf@os-s.net>
28 Version: %{ver}
29
30 # The entire source code is ASL 2.0 except datapath/ which is GPLv2
31 License: GPLv2
32 Release: %{?snapver:0.%{snapver}.}%{rel}%{?dist}
33 Source0: %{name}-%{srcver}.tar.gz
34 #Source1: openvswitch-init
35 Buildroot: /tmp/openvswitch-xen-rpm
36
37 # Add vxLan gpe NSH
38 Patch1: 0001-ovs-vxlan-gpe-vxlan-extension-to-support-vxlan-gpe-t.patch
39 Patch2: 0002-ovs-nsh-support-push-and-pop-actions-for-vxlan-gpe-a.patch
40 Patch3: 0003-Add-userspace-dataplane-nsh-support-and-remove-push_.patch
41 Patch4: 0004-Fix-too-large-stack-frame-size.patch
42 Patch5: 0005-Ethernet-header-must-be-kept-in-VxLAN-gpe-eth-NSH-fo.patch
43 Patch6: 0006-Fix-VxLAN-gpe-Eth-NSH-issues.patch
44
45 %description
46 Open vSwitch provides standard network bridging functions augmented with
47 support for the OpenFlow protocol for remote per-flow control of
48 traffic. This package contains the kernel modules.
49
50 %prep
51 %setup -q -n %{name}-%{srcver}
52 %patch1 -p1
53 %patch2 -p1
54 %patch3 -p1
55 %patch4 -p1
56 %patch5 -p1
57 %patch6 -p1
58
59 %build
60 autoreconf -i
61 %configure --with-linux=/lib/modules/%{kernel}/build --enable-ssl
62 make %{_smp_mflags} -C datapath/linux
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 make INSTALL_MOD_PATH=$RPM_BUILD_ROOT -C datapath/linux modules_install
67 mkdir -p $RPM_BUILD_ROOT/etc/depmod.d
68 for module in $RPM_BUILD_ROOT/lib/modules/%{kernel}/extra/*.ko
69 do
70     modname="$(basename ${module})"
71     echo "override ${modname%.ko} * extra" >> \
72         $RPM_BUILD_ROOT/etc/depmod.d/kmod-openvswitch.conf
73 done
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 # Ensure that modprobe will find our modules.
80 depmod %{kernel}
81
82 %files
83 %defattr(0644,root,root)
84 /lib/modules/%{kernel}/extra/*.ko
85 /etc/depmod.d/kmod-openvswitch.conf
86 %exclude /lib/modules/%{kernel}/modules.*
87
88 %changelog
89 * Wed Sep 21 2011 Kyle Mestery <kmestery@cisco.com>
90 - Updated for F15
91 * Wed Jan 12 2011 Ralf Spenneberg <ralf@os-s.net>
92 - First build on F14