Adds missing queens deploy settings files
[apex.git] / build / rpm_specs / opnfv-apex.spec
1 %global srcname opnfv-apex
2
3 Name:           python34-%{srcname}
4 Version:        7.0
5 Release:        %{_release}
6 Summary:        Scripts for OPNFV deployment using Apex
7
8 Group:          System Environment
9 License:        Apache 2.0
10 URL:            https://gerrit.opnfv.org/gerrit/apex.git
11 Source0:        opnfv-apex.tar.gz
12
13 BuildArch:      noarch
14 BuildRequires:  python34-docutils python34-devel
15 Requires:       openvswitch qemu-kvm bridge-utils libguestfs-tools python34-libvirt
16 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python34-jinja2 python3-ipmi python34-virtualbmc
17 Requires:       ipxe-roms-qemu >= 20160127-1
18 Requires:       libvirt-devel ansible
19 Requires:       python34-iptables python34-cryptography python34-pbr
20 Requires:       python34-GitPython python34-pygerrit2 python34-distro
21 Requires:       git
22
23 %description
24 Scripts for OPNFV deployment using Apex
25 https://wiki.opnfv.org/apex
26
27 %prep
28 %autosetup -n %{srcname}-%{version}
29
30 %build
31 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
32 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
33 %py3_build
34
35 %global __python %{__python3}
36
37 %install
38 mkdir -p %{buildroot}%{_bindir}/
39 %py3_install
40 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
41
42 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
43 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
44
45 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
46 cp -f %{buildroot}%{_datadir}/opnfv-apex/config/deploy/* %{buildroot}%{_sysconfdir}/opnfv-apex/
47 cp -f %{buildroot}%{_datadir}/opnfv-apex/config/network/* %{buildroot}%{_sysconfdir}/opnfv-apex/
48 rm -f %{buildroot}%{_sysconfdir}/opnfv-apex/deploy_settings.yaml
49
50 mkdir -p %{buildroot}%{_docdir}/opnfv/
51 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
52 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
53 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
54 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
55 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
56 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
57 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
58 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
59
60 %files
61 %{python3_sitelib}/apex/
62 %{python3_sitelib}/apex-*.egg-info
63 %defattr(644, root, root, 644)
64 %attr(755,root,root) %{_bindir}/opnfv-deploy
65 %attr(755,root,root) %{_bindir}/opnfv-clean
66 %attr(755,root,root) %{_bindir}/opnfv-util
67 %attr(755,root,root) %{_bindir}/opnfv-pyutil
68 %{_datadir}/opnfv-apex/
69 %{_sysconfdir}/bash_completion.d/apex
70 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
71 %{_sysconfdir}/opnfv-apex/os-nosdn-bar-noha.yaml
72 %{_sysconfdir}/opnfv-apex/os-nosdn-bar-ha.yaml
73 %{_sysconfdir}/opnfv-apex/os-nosdn-calipso-noha.yaml
74 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
75 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
76 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-noha.yaml
77 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
78 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
79 %{_sysconfdir}/opnfv-apex/os-nosdn-queens-noha.yaml
80 %{_sysconfdir}/opnfv-apex/os-nosdn-queens-ha.yaml
81 %{_sysconfdir}/opnfv-apex/os-odl-queens-noha.yaml
82 %{_sysconfdir}/opnfv-apex/os-odl-queens-ha.yaml
83 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-ha.yaml
84 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
85 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
86 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm_ovs_dpdk-ha.yaml
87 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm_ovs_dpdk-noha.yaml
88 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
89 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
90 %{_sysconfdir}/opnfv-apex/os-odl-sfc-ha.yaml
91 %{_sysconfdir}/opnfv-apex/os-odl-sfc-noha.yaml
92 %{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
93 %{_sysconfdir}/opnfv-apex/os-odl_netvirt-fdio-noha.yaml
94 %{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
95 %{_sysconfdir}/opnfv-apex/os-odl-fdio_dvr-ha.yaml
96 %{_sysconfdir}/opnfv-apex/os-odl-fdio_dvr-noha.yaml
97 %{_sysconfdir}/opnfv-apex/os-odl-l2gw-ha.yaml
98 %{_sysconfdir}/opnfv-apex/os-odl-l2gw-noha.yaml
99 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-noha.yaml
100 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-ha.yaml
101 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
102 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
103 %{_sysconfdir}/opnfv-apex/os-odl-sriov-ha.yaml
104 %{_sysconfdir}/opnfv-apex/os-odl-sriov-noha.yaml
105 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
106 %{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
107 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
108 %{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
109 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
110 %{_sysconfdir}/opnfv-apex/network_settings.yaml
111 %{_sysconfdir}/opnfv-apex/network_settings_csit.yaml
112 %{_sysconfdir}/opnfv-apex/network_settings_vlans.yaml
113 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
114 %doc %{_docdir}/opnfv/LICENSE.rst
115 %doc %{_docdir}/opnfv/installation-instructions.html
116 %doc %{_docdir}/opnfv/release-notes.rst
117 %doc %{_docdir}/opnfv/release-notes.html
118 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
119 %doc %{_docdir}/opnfv/network_settings.yaml.example
120 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
121 %doc %{_docdir}/opnfv/inventory.yaml.example
122
123 %changelog
124 * Fri Jun 15 2018 Tim Rozet <trozet@redhat.com> - 7.0-2
125   Adds missing HA deploy settings for Queens
126 * Fri May 25 2018 Tim Rozet <trozet@redhat.com> - 7.0-1
127   Adds CSIT network settings file
128 * Wed May 02 2018 Tim Rozet <trozet@redhat.com> - 7.0-0
129   Updates master with new version and deploy settings
130 * Tue Apr 17 2018 Feng Pan <fpan@redhat.com> - 6.0-4
131   Removes network_settings_vpp.yaml
132 * Tue Apr 03 2018 Tim Rozet <trozet@redhat.com> - 6.0-3
133   Adds fetch logs
134 * Fri Mar 09 2018 Tim Rozet <trozet@redhat.com> - 6.0-2
135   Add upstream deploy files with containers
136 * Wed Feb 14 2018 Tim Rozet <trozet@redhat.com> - 6.0-1
137   Fix docutils requirement and add python34-distro
138 * Wed Nov 29 2017 Tim Rozet <trozet@redhat.com> - 6.0-0
139   Bump version for Fraser
140 * Wed Oct 25 2017 Tim Rozet <trozet@redhat.com> - 5.0-9
141 - Adds GitPython and pygerrit2 dependencies
142 * Mon Oct 2 2017 Tim Rozet <trozet@redhat.com> - 5.0-8
143 - Adds upstream deployment scenario
144 * Wed Sep 20 2017 Tim Rozet <trozet@redhat.com> - 5.0-7
145 - Add calipso
146 * Fri Sep 08 2017 Tim Rozet <trozet@redhat.com> - 5.0-6
147 - Updates clean to use python
148 * Wed Aug 23 2017 Tim Rozet <trozet@redhat.com> - 5.0-5
149 - Updated requirements
150 * Mon Aug 14 2017 Tim Rozet <trozet@redhat.com> - 5.0-4
151 - Updated for python refactoring
152 * Mon May 08 2017 Dan Radez <dradez@redhat.com> - 5.0-3
153 - adding configure-vm
154 * Tue Apr 11 2017 Dan Radez <dradez@redhat.com> - 5.0-2
155 - Remove l2 scenario files
156 * Tue Apr 04 2017 Dan Radez <dradez@redhat.com> - 5.0-1
157 - Version update for Euphrates
158 - rename to ovs_dpdk
159 * Wed Mar 29 2017 Dan Radez <dradez@redhat.com> - 4.0-9
160 - Remove odl_l2-nofeature scenario file
161 - rename all odl_l3 scenario files to odl
162 * Thu Mar 23 2017 Tim Rozet <trozet@redhat.com> - 4.0-8
163 - Adds os-odl_l3-ovs-ha and noha scenarios
164 * Sun Mar 12 2017 Feng Pan <fpan@redhat.com> - 4.0-7
165 - Add os-nosdn-fdio-ha.yaml
166 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
167 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
168 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
169 - Adding kvm4nfv files
170 - Adding OVN files
171 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
172 - Add network_settings_vpp.yaml
173 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
174 - change odl_l3-gluon-noha to odl-gluon-noha
175 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
176 - Add odl_l3-gluon-noha config file
177 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
178 - Version update for Danube
179 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
180 - adding bash completion script
181 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
182 - Add clean library.
183 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
184 - Add nosdn fdio scenarios.
185 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
186 - Adding functions.sh files
187 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
188 - Add fdio scenarios.
189 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
190 - Add network_settings_v6.yaml
191 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
192 - Add custom libvirt domain.xml.
193 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
194 - Add performance deployment file
195 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
196 - Fixes python3 dependency.
197 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
198 - Adds dependency for python34-setuptools
199 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
200 - Adds python network setting parsing lib.
201 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
202 - Adds python ip utility lib.
203 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
204 - adding opnfv-util
205 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
206 - Version update for Colorado
207 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
208 - adding dependencies initscripts net-tools iputils iproute iptables
209 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
210 - Adds example inventory file and nosdn scenario
211 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
212 - Updating the installation instructions
213 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
214 - Package Split