Updates Calipso deploy settings
[apex.git] / build / rpm_specs / opnfv-apex.spec
1 %global srcname opnfv-apex
2
3 Name:           python34-%{srcname}
4 Version:        7.0
5 Release:        %{_release}
6 Summary:        Scripts for OPNFV deployment using Apex
7
8 Group:          System Environment
9 License:        Apache 2.0
10 URL:            https://gerrit.opnfv.org/gerrit/apex.git
11 Source0:        opnfv-apex.tar.gz
12
13 BuildArch:      noarch
14 BuildRequires:  python34-docutils python34-devel
15 Requires:       openvswitch qemu-kvm bridge-utils libguestfs-tools python34-libvirt
16 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python34-jinja2 python3-ipmi python34-virtualbmc
17 Requires:       ipxe-roms-qemu >= 20160127-1
18 Requires:       libvirt-devel ansible
19 Requires:       python34-iptables python34-cryptography python34-pbr
20 Requires:       python34-GitPython python34-pygerrit2 python34-distro
21 Requires:       git
22
23 %description
24 Scripts for OPNFV deployment using Apex
25 https://wiki.opnfv.org/apex
26
27 %prep
28 %autosetup -n %{srcname}-%{version}
29
30 %build
31 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
32 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
33 %py3_build
34
35 %global __python %{__python3}
36
37 %install
38 mkdir -p %{buildroot}%{_bindir}/
39 %py3_install
40 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
41
42 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
43 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
44
45 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
46 cp -f %{buildroot}%{_datadir}/opnfv-apex/config/deploy/* %{buildroot}%{_sysconfdir}/opnfv-apex/
47 cp -f %{buildroot}%{_datadir}/opnfv-apex/config/network/* %{buildroot}%{_sysconfdir}/opnfv-apex/
48 rm -f %{buildroot}%{_sysconfdir}/opnfv-apex/deploy_settings.yaml
49
50 mkdir -p %{buildroot}%{_docdir}/opnfv/
51 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
52 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
53 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
54 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
55 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
56 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
57 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
58 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
59
60 %files
61 %{python3_sitelib}/apex/
62 %{python3_sitelib}/apex-*.egg-info
63 %defattr(644, root, root, 644)
64 %attr(755,root,root) %{_bindir}/opnfv-deploy
65 %attr(755,root,root) %{_bindir}/opnfv-clean
66 %attr(755,root,root) %{_bindir}/opnfv-util
67 %attr(755,root,root) %{_bindir}/opnfv-pyutil
68 %{_datadir}/opnfv-apex/
69 %{_sysconfdir}/bash_completion.d/apex
70 %{_sysconfdir}/opnfv-apex/common-patches.yaml
71 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
72 %{_sysconfdir}/opnfv-apex/os-nosdn-bar-noha.yaml
73 %{_sysconfdir}/opnfv-apex/os-nosdn-bar-ha.yaml
74 %{_sysconfdir}/opnfv-apex/os-nosdn-calipso-noha.yaml
75 %{_sysconfdir}/opnfv-apex/os-nosdn-calipso_queens-noha.yaml
76 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
77 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
78 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-noha.yaml
79 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
80 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
81 %{_sysconfdir}/opnfv-apex/os-nosdn-queens-noha.yaml
82 %{_sysconfdir}/opnfv-apex/os-nosdn-queens-ha.yaml
83 %{_sysconfdir}/opnfv-apex/os-odl-queens-noha.yaml
84 %{_sysconfdir}/opnfv-apex/os-odl-queens-ha.yaml
85 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-ha.yaml
86 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
87 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
88 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm_ovs_dpdk-ha.yaml
89 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm_ovs_dpdk-noha.yaml
90 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
91 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
92 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn_queens-ha.yaml
93 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn_queens-noha.yaml
94 %{_sysconfdir}/opnfv-apex/os-odl-sfc-ha.yaml
95 %{_sysconfdir}/opnfv-apex/os-odl-sfc-noha.yaml
96 %{_sysconfdir}/opnfv-apex/os-odl-sfc_queens-ha.yaml
97 %{_sysconfdir}/opnfv-apex/os-odl-sfc_queens-noha.yaml
98 %{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
99 %{_sysconfdir}/opnfv-apex/os-odl_netvirt-fdio-noha.yaml
100 %{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
101 %{_sysconfdir}/opnfv-apex/os-odl-fdio_dvr-ha.yaml
102 %{_sysconfdir}/opnfv-apex/os-odl-fdio_dvr-noha.yaml
103 %{_sysconfdir}/opnfv-apex/os-odl-l2gw-ha.yaml
104 %{_sysconfdir}/opnfv-apex/os-odl-l2gw-noha.yaml
105 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-noha.yaml
106 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-ha.yaml
107 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
108 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
109 %{_sysconfdir}/opnfv-apex/os-odl-sriov-ha.yaml
110 %{_sysconfdir}/opnfv-apex/os-odl-sriov-noha.yaml
111 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
112 %{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
113 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
114 %{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
115 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
116 %{_sysconfdir}/opnfv-apex/network_settings.yaml
117 %{_sysconfdir}/opnfv-apex/network_settings_csit.yaml
118 %{_sysconfdir}/opnfv-apex/network_settings_vlans.yaml
119 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
120 %{_sysconfdir}/opnfv-apex/k8s-nosdn-nofeature-noha.yaml
121 %{_sysconfdir}/opnfv-apex/network_settings_tenant_vlan.yaml
122 %doc %{_docdir}/opnfv/LICENSE.rst
123 %doc %{_docdir}/opnfv/installation-instructions.html
124 %doc %{_docdir}/opnfv/release-notes.rst
125 %doc %{_docdir}/opnfv/release-notes.html
126 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
127 %doc %{_docdir}/opnfv/network_settings.yaml.example
128 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
129 %doc %{_docdir}/opnfv/inventory.yaml.example
130
131 %changelog
132 * Fri Aug 24 2018 Tim Rozet <trozet@redhat.com> - 7.0-7
133   Add Calipso for Queens
134 * Tue Aug 21 2018 Ricardo Noriega <rnoriega@redhat.com> - 7.0-6
135   Enable SFC scenarios for Gambia
136 * Tue Aug 14 2018 Tim Rozet <trozet@redhat.com> - 7.0-5
137   Adds common patches file
138 * Wed Jun 27 2018 Feng Pan <fpan@redhat.com> - 7.0-4
139   Adds network_settings_tenant_vlan.yaml
140 * Wed Jun 20 2018 Zenghui Shi <zshi@redhat.com> - 7.0-3
141   Adds Kubernetes deployment scenario
142 * Fri Jun 15 2018 Tim Rozet <trozet@redhat.com> - 7.0-2
143   Adds missing HA deploy settings for Queens
144 * Fri May 25 2018 Tim Rozet <trozet@redhat.com> - 7.0-1
145   Adds CSIT network settings file
146 * Wed May 02 2018 Tim Rozet <trozet@redhat.com> - 7.0-0
147   Updates master with new version and deploy settings
148 * Tue Apr 17 2018 Feng Pan <fpan@redhat.com> - 6.0-4
149   Removes network_settings_vpp.yaml
150 * Tue Apr 03 2018 Tim Rozet <trozet@redhat.com> - 6.0-3
151   Adds fetch logs
152 * Fri Mar 09 2018 Tim Rozet <trozet@redhat.com> - 6.0-2
153   Add upstream deploy files with containers
154 * Wed Feb 14 2018 Tim Rozet <trozet@redhat.com> - 6.0-1
155   Fix docutils requirement and add python34-distro
156 * Wed Nov 29 2017 Tim Rozet <trozet@redhat.com> - 6.0-0
157   Bump version for Fraser
158 * Wed Oct 25 2017 Tim Rozet <trozet@redhat.com> - 5.0-9
159 - Adds GitPython and pygerrit2 dependencies
160 * Mon Oct 2 2017 Tim Rozet <trozet@redhat.com> - 5.0-8
161 - Adds upstream deployment scenario
162 * Wed Sep 20 2017 Tim Rozet <trozet@redhat.com> - 5.0-7
163 - Add calipso
164 * Fri Sep 08 2017 Tim Rozet <trozet@redhat.com> - 5.0-6
165 - Updates clean to use python
166 * Wed Aug 23 2017 Tim Rozet <trozet@redhat.com> - 5.0-5
167 - Updated requirements
168 * Mon Aug 14 2017 Tim Rozet <trozet@redhat.com> - 5.0-4
169 - Updated for python refactoring
170 * Mon May 08 2017 Dan Radez <dradez@redhat.com> - 5.0-3
171 - adding configure-vm
172 * Tue Apr 11 2017 Dan Radez <dradez@redhat.com> - 5.0-2
173 - Remove l2 scenario files
174 * Tue Apr 04 2017 Dan Radez <dradez@redhat.com> - 5.0-1
175 - Version update for Euphrates
176 - rename to ovs_dpdk
177 * Wed Mar 29 2017 Dan Radez <dradez@redhat.com> - 4.0-9
178 - Remove odl_l2-nofeature scenario file
179 - rename all odl_l3 scenario files to odl
180 * Thu Mar 23 2017 Tim Rozet <trozet@redhat.com> - 4.0-8
181 - Adds os-odl_l3-ovs-ha and noha scenarios
182 * Sun Mar 12 2017 Feng Pan <fpan@redhat.com> - 4.0-7
183 - Add os-nosdn-fdio-ha.yaml
184 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
185 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
186 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
187 - Adding kvm4nfv files
188 - Adding OVN files
189 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
190 - Add network_settings_vpp.yaml
191 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
192 - change odl_l3-gluon-noha to odl-gluon-noha
193 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
194 - Add odl_l3-gluon-noha config file
195 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
196 - Version update for Danube
197 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
198 - adding bash completion script
199 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
200 - Add clean library.
201 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
202 - Add nosdn fdio scenarios.
203 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
204 - Adding functions.sh files
205 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
206 - Add fdio scenarios.
207 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
208 - Add network_settings_v6.yaml
209 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
210 - Add custom libvirt domain.xml.
211 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
212 - Add performance deployment file
213 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
214 - Fixes python3 dependency.
215 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
216 - Adds dependency for python34-setuptools
217 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
218 - Adds python network setting parsing lib.
219 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
220 - Adds python ip utility lib.
221 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
222 - adding opnfv-util
223 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
224 - Version update for Colorado
225 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
226 - adding dependencies initscripts net-tools iputils iproute iptables
227 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
228 - Adds example inventory file and nosdn scenario
229 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
230 - Updating the installation instructions
231 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
232 - Package Split