Updates scenario files for hunter branch
[apex.git] / build / rpm_specs / opnfv-apex.spec
1 %global srcname opnfv-apex
2
3 Name:           python34-%{srcname}
4 Version:        8.0
5 Release:        %{_release}
6 Summary:        Scripts for OPNFV deployment using Apex
7
8 Group:          System Environment
9 License:        Apache 2.0
10 URL:            https://gerrit.opnfv.org/gerrit/apex.git
11 Source0:        opnfv-apex.tar.gz
12
13 BuildArch:      noarch
14 BuildRequires:  python34-docutils python34-devel
15 Requires:       openvswitch qemu-kvm bridge-utils libguestfs-tools python34-libvirt
16 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python34-jinja2 python3-ipmi python34-virtualbmc
17 Requires:       ipxe-roms-qemu >= 20160127-1
18 Requires:       libvirt-devel ansible
19 Requires:       python34-iptables python34-cryptography python34-pbr
20 Requires:       python34-GitPython python34-pygerrit2 python34-distro
21 Requires:       git
22
23 %description
24 Scripts for OPNFV deployment using Apex
25 https://wiki.opnfv.org/apex
26
27 %prep
28 %autosetup -n %{srcname}-%{version}
29
30 %build
31 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
32 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
33 %py3_build
34
35 %global __python %{__python3}
36
37 %install
38 mkdir -p %{buildroot}%{_bindir}/
39 %py3_install
40 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
41
42 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
43 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
44
45 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
46 cp -f %{buildroot}%{_datadir}/opnfv-apex/config/deploy/* %{buildroot}%{_sysconfdir}/opnfv-apex/
47 cp -f %{buildroot}%{_datadir}/opnfv-apex/config/network/* %{buildroot}%{_sysconfdir}/opnfv-apex/
48 rm -f %{buildroot}%{_sysconfdir}/opnfv-apex/deploy_settings.yaml
49
50 mkdir -p %{buildroot}%{_docdir}/opnfv/
51 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
52 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
53 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
54 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
55 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
56 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
57 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
58 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
59
60 %files
61 %{python3_sitelib}/apex/
62 %{python3_sitelib}/apex-*.egg-info
63 %defattr(644, root, root, 644)
64 %attr(755,root,root) %{_bindir}/opnfv-deploy
65 %attr(755,root,root) %{_bindir}/opnfv-clean
66 %attr(755,root,root) %{_bindir}/opnfv-util
67 %attr(755,root,root) %{_bindir}/opnfv-pyutil
68 %{_datadir}/opnfv-apex/
69 %{_sysconfdir}/bash_completion.d/apex
70 %{_sysconfdir}/opnfv-apex/common-patches.yaml
71 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
72 %{_sysconfdir}/opnfv-apex/os-nosdn-bar-noha.yaml
73 %{_sysconfdir}/opnfv-apex/os-nosdn-bar-ha.yaml
74 %{_sysconfdir}/opnfv-apex/os-nosdn-calipso-noha.yaml
75 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
76 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
77 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-noha.yaml
78 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
79 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
80 %{_sysconfdir}/opnfv-apex/os-odl-queens-noha.yaml
81 %{_sysconfdir}/opnfv-apex/os-odl-queens-ha.yaml
82 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-ha.yaml
83 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
84 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
85 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm_ovs_dpdk-ha.yaml
86 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm_ovs_dpdk-noha.yaml
87 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
88 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
89 %{_sysconfdir}/opnfv-apex/os-odl-sfc-ha.yaml
90 %{_sysconfdir}/opnfv-apex/os-odl-sfc-noha.yaml
91 %{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
92 %{_sysconfdir}/opnfv-apex/os-odl_netvirt-fdio-noha.yaml
93 %{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
94 %{_sysconfdir}/opnfv-apex/os-odl-fdio_dvr-ha.yaml
95 %{_sysconfdir}/opnfv-apex/os-odl-fdio_dvr-noha.yaml
96 %{_sysconfdir}/opnfv-apex/os-odl-l2gw-ha.yaml
97 %{_sysconfdir}/opnfv-apex/os-odl-l2gw-noha.yaml
98 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-noha.yaml
99 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-ha.yaml
100 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
101 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
102 %{_sysconfdir}/opnfv-apex/os-odl-sriov-ha.yaml
103 %{_sysconfdir}/opnfv-apex/os-odl-sriov-noha.yaml
104 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
105 %{_sysconfdir}/opnfv-apex/os-ovn-nofeature-ha.yaml
106 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
107 %{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
108 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
109 %{_sysconfdir}/opnfv-apex/network_settings.yaml
110 %{_sysconfdir}/opnfv-apex/network_settings_csit.yaml
111 %{_sysconfdir}/opnfv-apex/network_settings_vlans.yaml
112 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
113 %{_sysconfdir}/opnfv-apex/k8s-nosdn-nofeature-noha.yaml
114 %{_sysconfdir}/opnfv-apex/network_settings_tenant_vlan.yaml
115 %doc %{_docdir}/opnfv/LICENSE.rst
116 %doc %{_docdir}/opnfv/installation-instructions.html
117 %doc %{_docdir}/opnfv/release-notes.rst
118 %doc %{_docdir}/opnfv/release-notes.html
119 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
120 %doc %{_docdir}/opnfv/network_settings.yaml.example
121 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
122 %doc %{_docdir}/opnfv/inventory.yaml.example
123
124 %changelog
125 * Fri Apr 26 2019 Tim Rozet <trozet@redhat.com> - 8.0-1
126   Update scenarios for Hunter release
127 * Thu Sep 27 2018 Tim Rozet <trozet@redhat.com> - 8.0-0
128   Updates from Queens to Rocky
129 * Fri Aug 24 2018 Tim Rozet <trozet@redhat.com> - 7.0-7
130   Add Calipso for Queens
131 * Tue Aug 21 2018 Ricardo Noriega <rnoriega@redhat.com> - 7.0-6
132   Enable SFC scenarios for Gambia
133 * Tue Aug 14 2018 Tim Rozet <trozet@redhat.com> - 7.0-5
134   Adds common patches file
135 * Wed Jun 27 2018 Feng Pan <fpan@redhat.com> - 7.0-4
136   Adds network_settings_tenant_vlan.yaml
137 * Wed Jun 20 2018 Zenghui Shi <zshi@redhat.com> - 7.0-3
138   Adds Kubernetes deployment scenario
139 * Fri Jun 15 2018 Tim Rozet <trozet@redhat.com> - 7.0-2
140   Adds missing HA deploy settings for Queens
141 * Fri May 25 2018 Tim Rozet <trozet@redhat.com> - 7.0-1
142   Adds CSIT network settings file
143 * Wed May 02 2018 Tim Rozet <trozet@redhat.com> - 7.0-0
144   Updates master with new version and deploy settings
145 * Tue Apr 17 2018 Feng Pan <fpan@redhat.com> - 6.0-4
146   Removes network_settings_vpp.yaml
147 * Tue Apr 03 2018 Tim Rozet <trozet@redhat.com> - 6.0-3
148   Adds fetch logs
149 * Fri Mar 09 2018 Tim Rozet <trozet@redhat.com> - 6.0-2
150   Add upstream deploy files with containers
151 * Wed Feb 14 2018 Tim Rozet <trozet@redhat.com> - 6.0-1
152   Fix docutils requirement and add python34-distro
153 * Wed Nov 29 2017 Tim Rozet <trozet@redhat.com> - 6.0-0
154   Bump version for Fraser
155 * Wed Oct 25 2017 Tim Rozet <trozet@redhat.com> - 5.0-9
156 - Adds GitPython and pygerrit2 dependencies
157 * Mon Oct 2 2017 Tim Rozet <trozet@redhat.com> - 5.0-8
158 - Adds upstream deployment scenario
159 * Wed Sep 20 2017 Tim Rozet <trozet@redhat.com> - 5.0-7
160 - Add calipso
161 * Fri Sep 08 2017 Tim Rozet <trozet@redhat.com> - 5.0-6
162 - Updates clean to use python
163 * Wed Aug 23 2017 Tim Rozet <trozet@redhat.com> - 5.0-5
164 - Updated requirements
165 * Mon Aug 14 2017 Tim Rozet <trozet@redhat.com> - 5.0-4
166 - Updated for python refactoring
167 * Mon May 08 2017 Dan Radez <dradez@redhat.com> - 5.0-3
168 - adding configure-vm
169 * Tue Apr 11 2017 Dan Radez <dradez@redhat.com> - 5.0-2
170 - Remove l2 scenario files
171 * Tue Apr 04 2017 Dan Radez <dradez@redhat.com> - 5.0-1
172 - Version update for Euphrates
173 - rename to ovs_dpdk
174 * Wed Mar 29 2017 Dan Radez <dradez@redhat.com> - 4.0-9
175 - Remove odl_l2-nofeature scenario file
176 - rename all odl_l3 scenario files to odl
177 * Thu Mar 23 2017 Tim Rozet <trozet@redhat.com> - 4.0-8
178 - Adds os-odl_l3-ovs-ha and noha scenarios
179 * Sun Mar 12 2017 Feng Pan <fpan@redhat.com> - 4.0-7
180 - Add os-nosdn-fdio-ha.yaml
181 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
182 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
183 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
184 - Adding kvm4nfv files
185 - Adding OVN files
186 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
187 - Add network_settings_vpp.yaml
188 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
189 - change odl_l3-gluon-noha to odl-gluon-noha
190 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
191 - Add odl_l3-gluon-noha config file
192 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
193 - Version update for Danube
194 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
195 - adding bash completion script
196 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
197 - Add clean library.
198 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
199 - Add nosdn fdio scenarios.
200 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
201 - Adding functions.sh files
202 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
203 - Add fdio scenarios.
204 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
205 - Add network_settings_v6.yaml
206 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
207 - Add custom libvirt domain.xml.
208 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
209 - Add performance deployment file
210 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
211 - Fixes python3 dependency.
212 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
213 - Adds dependency for python34-setuptools
214 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
215 - Adds python network setting parsing lib.
216 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
217 - Adds python ip utility lib.
218 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
219 - adding opnfv-util
220 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
221 - Version update for Colorado
222 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
223 - adding dependencies initscripts net-tools iputils iproute iptables
224 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
225 - Adds example inventory file and nosdn scenario
226 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
227 - Updating the installation instructions
228 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
229 - Package Split