Add networking-vpp ML2 support
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        4.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2 python3-ipmi
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
26 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
37 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
38
39 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
40 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
41 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
42 install config/deploy/os-nosdn-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
43 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
44 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
45 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
46 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
47 install config/deploy/os-nosdn-kvm-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
48 install config/deploy/os-nosdn-kvm-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
49 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
50 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
51 install config/deploy/os-odl-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
52 install config/deploy/os-odl-bgpvpn-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
53 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
54 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
55 install config/deploy/os-odl_l3-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-noha.yaml
56 install config/deploy/os-odl_l3-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-ha.yaml
57 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
58 install config/deploy/os-odl-gluon-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
59 #install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
60 #install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
61 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
62 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
63 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
64 install config/network/network_settings_vpp.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
65
66
67 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
68 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
69 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
70 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
71 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
72 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
73 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
74 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
75 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
76 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
77 mkdir -p %{buildroot}%{python3_sitelib}/apex/
78 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
79 install lib/python/apex/deploy_settings.py %{buildroot}%{python3_sitelib}/apex/
80 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
81 install lib/python/apex/inventory.py %{buildroot}%{python3_sitelib}/apex/
82 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
83 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
84 install lib/python/apex/clean.py %{buildroot}%{python3_sitelib}/apex/
85 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
86 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
87 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
88 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
89 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
90 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
91 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
92
93 mkdir -p %{buildroot}%{_docdir}/opnfv/
94 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
95 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
96 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
97 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
98 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
99 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
100 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
101 install config/network/network_settings_vpp.yaml %{buildroot}%{_docdir}/opnfv/network_settings_vpp.yaml.example
102 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
103
104 %files
105 %defattr(644, root, root, -)
106 %attr(755,root,root) %{_bindir}/opnfv-deploy
107 %attr(755,root,root) %{_bindir}/opnfv-clean
108 %attr(755,root,root) %{_bindir}/opnfv-util
109 %{_var}/opt/opnfv/lib/common-functions.sh
110 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
111 %{_var}/opt/opnfv/lib/parse-functions.sh
112 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
113 %{_var}/opt/opnfv/lib/undercloud-functions.sh
114 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
115 %{_var}/opt/opnfv/lib/post-install-functions.sh
116 %{_var}/opt/opnfv/lib/utility-functions.sh
117 %{_var}/opt/opnfv/lib/python/
118 %{python3_sitelib}/apex/
119 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
120 %{_var}/opt/opnfv/lib/installer/domain.xml
121 %{_sysconfdir}/bash_completion.d/apex
122 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
123 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
124 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
125 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
126 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
127 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
128 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
129 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
130 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
131 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
132 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
133 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
134 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
135 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
136 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
137 %{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-noha.yaml
138 %{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-ha.yaml
139 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
140 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
141 #%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
142 #%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
143 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
144 %{_sysconfdir}/opnfv-apex/network_settings.yaml
145 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
146 %{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
147 %doc %{_docdir}/opnfv/LICENSE.rst
148 %doc %{_docdir}/opnfv/installation-instructions.html
149 %doc %{_docdir}/opnfv/release-notes.rst
150 %doc %{_docdir}/opnfv/release-notes.html
151 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
152 %doc %{_docdir}/opnfv/network_settings.yaml.example
153 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
154 %doc %{_docdir}/opnfv/network_settings_vpp.yaml.example
155 %doc %{_docdir}/opnfv/inventory.yaml.example
156
157 %changelog
158 * Mon Mar 12 2017 Feng Pan <fpan@redhat.com> - 4.0-7
159 - Add os-nosdn-fdio-ha.yaml
160 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
161 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
162 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
163 - Commenting out ONOS, unsupported in Danube
164 - Adding kvm4nfv files
165 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
166 - Add network_settings_vpp.yaml
167 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
168 - change odl_l3-gluon-noha to odl-gluon-noha
169 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
170 - Add odl_l3-gluon-noha config file
171 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
172 - Version update for Danube
173 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
174 - adding bash completion script
175 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
176 - Add clean library.
177 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
178 - Add nosdn fdio scenarios.
179 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
180 - Adding functions.sh files
181 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
182 - Add fdio scenarios.
183 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
184 - Add network_settings_v6.yaml
185 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
186 - Add custom libvirt domain.xml.
187 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
188 - Add performance deployment file
189 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
190 - Fixes python3 dependency.
191 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
192 - Adds dependency for python34-setuptools
193 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
194 - Adds python network setting parsing lib.
195 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
196 - Adds python ip utility lib.
197 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
198 - adding opnfv-util
199 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
200 - Version update for Colorado
201 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
202 - adding dependencies initscripts net-tools iputils iproute iptables
203 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
204 - Adds example inventory file and nosdn scenario
205 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
206 - Updating the installation instructions
207 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
208 - Package Split