Fixes missing permissions on configure-vm
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        5.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools libvirt-python
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python34-jinja2 python3-ipmi python2-virtualbmc
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
26 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
37 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
38
39 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
40 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
41 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
42 install config/deploy/os-nosdn-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
43 install config/deploy/os-nosdn-ovs_dpdk-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-noha.yaml
44 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
45 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
46 install config/deploy/os-nosdn-ovs_dpdk-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-ha.yaml
47 install config/deploy/os-nosdn-kvm-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
48 install config/deploy/os-nosdn-kvm-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
49 install config/deploy/os-odl-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
50 install config/deploy/os-odl-bgpvpn-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
51 install config/deploy/os-odl-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
52 install config/deploy/os-odl_netvirt-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_netvirt-fdio-noha.yaml
53 install config/deploy/os-odl-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
54 install config/deploy/os-odl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
55 install config/deploy/os-odl-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
56 install config/deploy/os-odl-ovs_dpdk-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-ha.yaml
57 install config/deploy/os-odl-ovs_dpdk-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-noha.yaml
58 install config/deploy/os-odl-gluon-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
59 install config/deploy/os-ovn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
60 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
61 install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
62 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
63 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
64 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
65 install config/network/network_settings_vpp.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
66
67
68 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
69 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
70 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
71 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
72 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
73 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
74 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
75 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
76 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
77 install lib/configure-vm %{buildroot}%{_var}/opt/opnfv/lib/
78 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
79 mkdir -p %{buildroot}%{python3_sitelib}/apex/
80 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
81 install lib/python/apex/deploy_settings.py %{buildroot}%{python3_sitelib}/apex/
82 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
83 install lib/python/apex/inventory.py %{buildroot}%{python3_sitelib}/apex/
84 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
85 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
86 install lib/python/apex/clean.py %{buildroot}%{python3_sitelib}/apex/
87 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
88 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
89 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
90 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
91 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
92 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
93
94 mkdir -p %{buildroot}%{_docdir}/opnfv/
95 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
96 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
97 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
98 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
99 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
100 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
101 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
102 install config/network/network_settings_vpp.yaml %{buildroot}%{_docdir}/opnfv/network_settings_vpp.yaml.example
103 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
104
105 %files
106 %defattr(644, root, root, -)
107 %attr(755,root,root) %{_bindir}/opnfv-deploy
108 %attr(755,root,root) %{_bindir}/opnfv-clean
109 %attr(755,root,root) %{_bindir}/opnfv-util
110 %{_var}/opt/opnfv/lib/common-functions.sh
111 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
112 %{_var}/opt/opnfv/lib/parse-functions.sh
113 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
114 %{_var}/opt/opnfv/lib/undercloud-functions.sh
115 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
116 %{_var}/opt/opnfv/lib/post-install-functions.sh
117 %{_var}/opt/opnfv/lib/utility-functions.sh
118 %attr(755,root,root) %{_var}/opt/opnfv/lib/configure-vm
119 %{_var}/opt/opnfv/lib/python/
120 %{python3_sitelib}/apex/
121 %{_var}/opt/opnfv/lib/installer/domain.xml
122 %{_sysconfdir}/bash_completion.d/apex
123 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
124 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
125 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
126 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-noha.yaml
127 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
128 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
129 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-ha.yaml
130 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
131 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
132 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
133 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
134 %{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
135 %{_sysconfdir}/opnfv-apex/os-odl_netvirt-fdio-noha.yaml
136 %{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
137 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-noha.yaml
138 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-ha.yaml
139 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
140 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
141 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
142 %{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
143 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
144 %{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
145 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
146 %{_sysconfdir}/opnfv-apex/network_settings.yaml
147 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
148 %{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
149 %doc %{_docdir}/opnfv/LICENSE.rst
150 %doc %{_docdir}/opnfv/installation-instructions.html
151 %doc %{_docdir}/opnfv/release-notes.rst
152 %doc %{_docdir}/opnfv/release-notes.html
153 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
154 %doc %{_docdir}/opnfv/network_settings.yaml.example
155 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
156 %doc %{_docdir}/opnfv/network_settings_vpp.yaml.example
157 %doc %{_docdir}/opnfv/inventory.yaml.example
158
159 %changelog
160 * Mon May 08 2017 Dan Radez <dradez@redhat.com> - 5.0-3
161 - adding configure-vm
162 * Tue Apr 11 2017 Dan Radez <dradez@redhat.com> - 5.0-2
163 - Remove l2 scenario files
164 * Tue Apr 04 2017 Dan Radez <dradez@redhat.com> - 5.0-1
165 - Version update for Euphrates
166 - rename to ovs_dpdk
167 * Wed Mar 29 2017 Dan Radez <dradez@redhat.com> - 4.0-9
168 - Remove odl_l2-nofeature scenario file
169 - rename all odl_l3 scenario files to odl
170 * Thu Mar 23 2017 Tim Rozet <trozet@redhat.com> - 4.0-8
171 - Adds os-odl_l3-ovs-ha and noha scenarios
172 * Mon Mar 12 2017 Feng Pan <fpan@redhat.com> - 4.0-7
173 - Add os-nosdn-fdio-ha.yaml
174 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
175 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
176 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
177 - Adding kvm4nfv files
178 - Adding OVN files
179 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
180 - Add network_settings_vpp.yaml
181 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
182 - change odl_l3-gluon-noha to odl-gluon-noha
183 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
184 - Add odl_l3-gluon-noha config file
185 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
186 - Version update for Danube
187 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
188 - adding bash completion script
189 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
190 - Add clean library.
191 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
192 - Add nosdn fdio scenarios.
193 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
194 - Adding functions.sh files
195 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
196 - Add fdio scenarios.
197 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
198 - Add network_settings_v6.yaml
199 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
200 - Add custom libvirt domain.xml.
201 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
202 - Add performance deployment file
203 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
204 - Fixes python3 dependency.
205 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
206 - Adds dependency for python34-setuptools
207 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
208 - Adds python network setting parsing lib.
209 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
210 - Adds python ip utility lib.
211 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
212 - adding opnfv-util
213 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
214 - Version update for Colorado
215 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
216 - adding dependencies initscripts net-tools iputils iproute iptables
217 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
218 - Adds example inventory file and nosdn scenario
219 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
220 - Updating the installation instructions
221 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
222 - Package Split