remove ceph code
[stor4nfv.git] / src / ceph / src / test / python / ceph / setup.py
diff --git a/src/ceph/src/test/python/ceph/setup.py b/src/ceph/src/test/python/ceph/setup.py
deleted file mode 100644 (file)
index 90dbb59..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-import os
-from setuptools import setup, find_packages
-
-# link ceph script here so we can "install" it
-current_dir = os.path.abspath(os.path.dirname(__file__))
-src_dir = os.path.dirname(os.path.dirname(os.path.dirname(current_dir)))
-script_path = os.path.join(src_dir, 'ceph.in')
-
-
-def link_target(source, destination):
-    if not os.path.exists(destination):
-        try:
-            os.symlink(source, destination)
-        except (IOError, OSError) as error:
-            print('Ignoring linking of target: %s' % str(error))
-
-link_target(script_path, 'ceph.py')
-
-setup(
-    name='ceph',
-    version='0.1',
-    description='',
-    author='',
-    author_email='',
-    zip_safe=False,
-    packages=find_packages(),
-)