remove ceph code
[stor4nfv.git] / src / ceph / src / test / python / brag-client / setup.py
diff --git a/src/ceph/src/test/python/brag-client/setup.py b/src/ceph/src/test/python/brag-client/setup.py
deleted file mode 100644 (file)
index 7f2bc7a..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-import os
-from setuptools import setup, find_packages
-
-# link ceph-brag client script here so we can "install" it
-current_dir = os.path.abspath(os.path.dirname(__file__))
-src_dir = os.path.dirname(os.path.dirname(os.path.dirname(current_dir)))
-script_path = os.path.join(src_dir, 'brag/client/ceph-brag')
-
-
-def link_target(source, destination):
-    if not os.path.exists(destination):
-        try:
-            os.symlink(source, destination)
-        except (IOError, OSError) as error:
-            print('Ignoring linking of target: %s' % str(error))
-
-link_target(script_path, 'ceph_brag.py')
-
-setup(
-    name='ceph_brag',
-    version='0.1',
-    description='',
-    author='',
-    author_email='',
-    install_requires=[
-        "requests",
-    ],
-    zip_safe=False,
-    packages=find_packages(),
-    #packages=find_packages(exclude=['ez_setup'])
-)