initial code repo
[stor4nfv.git] / src / ceph / src / ceph-detect-init / CMakeLists.txt
diff --git a/src/ceph/src/ceph-detect-init/CMakeLists.txt b/src/ceph/src/ceph-detect-init/CMakeLists.txt
new file mode 100644 (file)
index 0000000..066be41
--- /dev/null
@@ -0,0 +1,12 @@
+set(CEPH_DETECT_INIT_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/ceph-detect-init-virtualenv)
+
+add_custom_target(ceph-detect-init
+  COMMAND
+  ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh ${CEPH_DETECT_INIT_VIRTUALENV} &&
+  ${CEPH_DETECT_INIT_VIRTUALENV}/bin/pip install --no-index --use-wheel --find-links=file:${CMAKE_SOURCE_DIR}/src/ceph-detect-init/wheelhouse -e .
+  WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-detect-init
+  COMMENT "ceph-detect-init is being created")
+add_dependencies(tests ceph-detect-init)
+
+include(Distutils)
+distutils_install_module(ceph_detect_init)