initial code repo
[stor4nfv.git] / src / ceph / doc / man / CMakeLists.txt
diff --git a/src/ceph/doc/man/CMakeLists.txt b/src/ceph/doc/man/CMakeLists.txt
new file mode 100644 (file)
index 0000000..e81631b
--- /dev/null
@@ -0,0 +1,15 @@
+set(sphinx_input)
+set(sphinx_output)
+set(sphinx_output_dir ${CMAKE_BINARY_DIR}/doc/man)
+
+add_subdirectory(8)
+
+add_custom_command(
+  OUTPUT ${sphinx_output}
+  COMMAND ${SPHINX_BUILD} -b man -t man -d ${CMAKE_BINARY_DIR}/doc/doctrees -c ${CMAKE_SOURCE_DIR}/man ${CMAKE_CURRENT_SOURCE_DIR} ${sphinx_output_dir}
+  DEPENDS ${sphinx_input})
+
+add_custom_target(
+  manpages ALL
+  DEPENDS ${sphinx_output}
+  COMMENT "manpages building")