parser script and step class in backend code of testing-scheduler
[bottlenecks.git] / testing-scheduler / server / setup.py
diff --git a/testing-scheduler/server/setup.py b/testing-scheduler/server/setup.py
new file mode 100644 (file)
index 0000000..398f876
--- /dev/null
@@ -0,0 +1,31 @@
+#!/usr/bin/env python\r
+##############################################################################\r
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd and others.\r
+#\r
+# All rights reserved. This program and the accompanying materials\r
+# are made available under the terms of the Apache License, Version 2.0\r
+# which accompanies this distribution, and is available at\r
+# http://www.apache.org/licenses/LICENSE-2.0\r
+##############################################################################\r
+'''This file realize the function of how to setup server of testing-scheduler\r
+to your environment. This use setuptools tool to setup'''\r
+\r
+from setuptools import setup, find_packages\r
+\r
+\r
+setup(\r
+    name="testing-scheduler-server",\r
+    version="0.1",\r
+    packages=find_packages(),\r
+    include_package_data=True,\r
+    package_data={\r
+        'src': [\r
+            'env/context/*.yaml',\r
+            'env/service/*.yaml',\r
+            'conductor_processor/*.json'\r
+        ],\r
+        'test': [\r
+            'test_case/*/*.yaml'\r
+        ]\r
+    }\r
+)\r