Add copyright header to patch files
[armband.git] / patches / fuel-plugin-ovs / 0002-deb-src-Enable-building-Debian-source-pkgs.patch
index c7b90a0..8451c68 100644 (file)
@@ -1,3 +1,11 @@
+::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
+: Copyright (c) 2017 Enea AB and others.
+:
+: All rights reserved. This program and the accompanying materials
+: are made available under the terms of the Apache License, Version 2.0
+: which accompanies this distribution, and is available at
+: http://www.apache.org/licenses/LICENSE-2.0
+::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
 From: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
 Date: Wed, 25 Jan 2017 22:11:44 +0100
 Subject: [PATCH] deb-src: Enable building Debian source pkgs
@@ -13,10 +21,10 @@ passing an useless env var to each docker run).
 Change-Id: I4e308d84c2eb01af043ed73440c46fc692c30d12
 Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
 ---
- ovs_build/build-ovs-dpdk.sh                        | 28 ++++++++++++++----
- ovs_build/build-ovs-nsh-dpdk.sh                    | 34 +++++++++++++++++-----
+ ovs_build/build-ovs-dpdk.sh                        | 28 +++++++++++++++++-----
+ ovs_build/build-ovs-nsh.sh                         | 26 +++++++++++++++++---
  .../debian/patches/series                          |  1 -
- 3 files changed, 49 insertions(+), 14 deletions(-)
+ 3 files changed, 45 insertions(+), 10 deletions(-)
  delete mode 100644 ovs_build/openvswitch_2.6-dpdk_16.07/debian/patches/series
 
 diff --git a/ovs_build/build-ovs-dpdk.sh b/ovs_build/build-ovs-dpdk.sh
@@ -87,11 +95,11 @@ index 7ce2a62..8dd7430 100755
 
  cp -r ${BUILD_HOME}/*.deb ${BUILD_HOME}/deb
  cd ${BUILD_HOME}/deb
-diff --git a/ovs_build/build-ovs-nsh-dpdk.sh b/ovs_build/build-ovs-nsh-dpdk.sh
-index e6f8faf..03b494c 100755
---- a/ovs_build/build-ovs-nsh-dpdk.sh
-+++ b/ovs_build/build-ovs-nsh-dpdk.sh
-@@ -11,14 +11,30 @@ DEB_ARCH="$(dpkg --print-architecture)"
+diff --git a/ovs_build/build-ovs-nsh.sh b/ovs_build/build-ovs-nsh.sh
+index dbebdb2..efbabab 100755
+--- a/ovs_build/build-ovs-nsh.sh
++++ b/ovs_build/build-ovs-nsh.sh
+@@ -11,6 +11,22 @@ DEB_ARCH="$(dpkg --print-architecture)"
 
  export DEB_BUILD_OPTIONS='parallel=8 nocheck'
 
@@ -114,26 +122,7 @@ index e6f8faf..03b494c 100755
  sudo apt-get update
  sudo apt-get -y --force-yes install devscripts dpkg-dev git wget dkms
 
- rm -rf ${BUILD_HOME}; mkdir -p ${BUILD_HOME}/deb
-
- cd ${BUILD_HOME}
--wget -c http://fast.dpdk.org/rel/dpdk-16.07.tar.xz
--xz -d dpdk-16.07.tar.xz; tar xvf dpdk-16.07.tar
-+wget -c http://fast.dpdk.org/rel/dpdk-16.07.tar.xz -O dpdk_16.07.orig.tar.xz
-+tar xJvf dpdk_16.07.orig.tar.xz
- cd dpdk-16.07
- cp -r ${BUILD_SRC}/dpdk_16.07.fuel/debian .
- cat << EOF > debian/changelog
-@@ -45,7 +61,7 @@ sudo apt-get install -y --force-yes debhelper \
-                python-sphinx  \
-                texlive-fonts-recommended  \
-                texlive-latex-extra
--debian/rules build; fakeroot debian/rules binary
-+debian_build
-
- cd ${BUILD_HOME}
- sudo apt-get install -y --force-yes hwdata
-@@ -73,12 +89,16 @@ sudo apt-get install -y --force-yes autoconf \
+@@ -39,12 +55,16 @@ sudo apt-get install -y --force-yes autoconf \
                 python-six
 
  git clone https://github.com/openvswitch/ovs.git
@@ -149,19 +138,10 @@ index e6f8faf..03b494c 100755
 +    patch -p1 < debian/patches/${patch}
  done
 +cp debian/patches/series .pc/applied-patches
- cd ${BUILD_HOME}; cp -r ovs ovs-dpdk
-
- cd ovs-dpdk
-@@ -91,7 +111,7 @@ openvswitch-dpdk (${OVS_VER}-1.nsh) unstable; urgency=low
-  -- Open vSwitch team <dev@openvswitch.org>  $(date --rfc-2822)
- EOF
 
--debian/rules build; fakeroot debian/rules binary
-+debian_build
-
- cd ${BUILD_HOME}/ovs
  cat << EOF > debian/changelog
-@@ -101,7 +121,7 @@ openvswitch (${OVS_VER}-1.nsh) unstable; urgency=low
+ openvswitch (${OVS_VER}-1.nsh) unstable; urgency=low
+@@ -53,7 +73,7 @@ openvswitch (${OVS_VER}-1.nsh) unstable; urgency=low
 
   -- Open vSwitch team <dev@openvswitch.org>  $(date --rfc-2822)
  EOF