a8dd3b75cdd3eab02647db70b7f52aedebeebd5e
[apex.git] / build / rpm_specs / zrpc.spec
1 Name: zrpcd
2 Version: 0.2
3 Release: 0
4
5 Summary: Zebra Remote Procedure Call
6 Group: Applications/Internet
7 License: GPL
8 Source0: %{name}-%{version}.tar.gz
9 Source1: zrpcd.service
10
11 BuildRequires:  systemd-units
12
13 Requires: thrift zeromq glib2 c-capnproto capnproto quagga
14 Requires(post): systemd
15 Requires(preun): systemd
16 Requires(postun): systemd
17 %description
18 ZRPC provides a Thrift API and handles RPC to configure Quagga framework.
19
20 %prep
21 %setup -q
22
23 %build
24
25 %configure
26
27 %install
28 mkdir -p %{buildroot}%{_unitdir}
29 install -p -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/zrpcd.service
30 %make_install
31
32 %post
33 %systemd_post zrpcd.service
34
35 %preun
36 %systemd_preun zrpcd.service
37
38 %postun
39 %systemd_postun_with_restart zrpcd.service
40
41 %files
42 %defattr(-,root,root)
43 %{_sbindir}/zrpcd
44 %{_includedir}/%name/zrpc_global.h
45 %{_includedir}/%name/zrpc_os_wrapper.h
46 %{_unitdir}/zrpcd.service