Merge "enable vhostuser for ovs-dpdk scenario"
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2 python3-ipmi
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/installationprocedure/index.rst docs/installation-instructions.html
26 rst2html docs/releasenotes/release-notes.rst docs/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
37 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
38
39 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
40 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
41 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
42 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
43 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
44 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
45 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
46 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
47 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
48 install config/deploy/os-odl_l2-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
49 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
50 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
51 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
52 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
53 install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
54 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
55 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
56 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
57
58
59 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
60 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
61 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
62 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
63 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
64 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
65 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
66 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
67 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
68 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
69 mkdir -p %{buildroot}%{python3_sitelib}/apex/
70 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
71 install lib/python/apex/deploy_settings.py %{buildroot}%{python3_sitelib}/apex/
72 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
73 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
74 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
75 install lib/python/apex/clean.py %{buildroot}%{python3_sitelib}/apex/
76 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
77 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
78 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
79 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
80 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
81 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
82 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
83
84 mkdir -p %{buildroot}%{_docdir}/opnfv/
85 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
86 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
87 install docs/releasenotes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
88 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
89 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
90 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
91 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
92 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
93
94 %files
95 %defattr(644, root, root, -)
96 %attr(755,root,root) %{_bindir}/opnfv-deploy
97 %attr(755,root,root) %{_bindir}/opnfv-clean
98 %attr(755,root,root) %{_bindir}/opnfv-util
99 %{_var}/opt/opnfv/lib/common-functions.sh
100 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
101 %{_var}/opt/opnfv/lib/parse-functions.sh
102 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
103 %{_var}/opt/opnfv/lib/undercloud-functions.sh
104 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
105 %{_var}/opt/opnfv/lib/post-install-functions.sh
106 %{_var}/opt/opnfv/lib/utility-functions.sh
107 %{_var}/opt/opnfv/lib/python/
108 %{python3_sitelib}/apex/
109 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
110 %{_var}/opt/opnfv/lib/installer/domain.xml
111 %{_sysconfdir}/bash_completion.d/apex
112 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
113 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
114 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
115 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
116 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
117 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
118 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
119 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
120 %{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
121 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
122 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
123 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
124 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
125 %{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
126 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
127 %{_sysconfdir}/opnfv-apex/network_settings.yaml
128 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
129 %doc %{_docdir}/opnfv/LICENSE.rst
130 %doc %{_docdir}/opnfv/installation-instructions.html
131 %doc %{_docdir}/opnfv/release-notes.rst
132 %doc %{_docdir}/opnfv/release-notes.html
133 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
134 %doc %{_docdir}/opnfv/network_settings.yaml.example
135 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
136 %doc %{_docdir}/opnfv/inventory.yaml.example
137
138 %changelog
139 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
140 - adding bash completion script
141 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
142 - Add clean library.
143 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
144 - Add nosdn fdio scenarios.
145 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
146 - Adding functions.sh files
147 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
148 - Add fdio scenarios.
149 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
150 - Add network_settings_v6.yaml
151 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
152 - Add custom libvirt domain.xml.
153 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
154 - Add performance deployment file
155 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
156 - Fixes python3 dependency.
157 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
158 - Adds dependency for python34-setuptools
159 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
160 - Adds python network setting parsing lib.
161 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
162 - Adds python ip utility lib.
163 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
164 - adding opnfv-util
165 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
166 - Version update for Colorado
167 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
168 - adding dependencies initscripts net-tools iputils iproute iptables
169 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
170 - Adds example inventory file and nosdn scenario
171 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
172 - Updating the installation instructions
173 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
174 - Package Split