Merge "Add noha scenario for bgpvpn"
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        4.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2 python3-ipmi
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/installationprocedure/index.rst docs/installation-instructions.html
26 rst2html docs/releasenotes/release-notes.rst docs/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
37 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
38
39 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
40 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
41 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
42 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
43 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
44 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
45 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
46 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
47 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
48 install config/deploy/os-odl_l2-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
49 install config/deploy/os-odl_l2-bgpvpn-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-noha.yaml
50 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
51 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
52 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
53 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
54 install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
55 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
56 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
57 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
58
59
60 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
61 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
62 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
63 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
64 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
65 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
66 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
67 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
68 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
69 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
70 mkdir -p %{buildroot}%{python3_sitelib}/apex/
71 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
72 install lib/python/apex/deploy_settings.py %{buildroot}%{python3_sitelib}/apex/
73 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
74 install lib/python/apex/inventory.py %{buildroot}%{python3_sitelib}/apex/
75 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
76 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
77 install lib/python/apex/clean.py %{buildroot}%{python3_sitelib}/apex/
78 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
79 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
80 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
81 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
82 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
83 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
84 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
85
86 mkdir -p %{buildroot}%{_docdir}/opnfv/
87 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
88 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
89 install docs/releasenotes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
90 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
91 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
92 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
93 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
94 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
95
96 %files
97 %defattr(644, root, root, -)
98 %attr(755,root,root) %{_bindir}/opnfv-deploy
99 %attr(755,root,root) %{_bindir}/opnfv-clean
100 %attr(755,root,root) %{_bindir}/opnfv-util
101 %{_var}/opt/opnfv/lib/common-functions.sh
102 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
103 %{_var}/opt/opnfv/lib/parse-functions.sh
104 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
105 %{_var}/opt/opnfv/lib/undercloud-functions.sh
106 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
107 %{_var}/opt/opnfv/lib/post-install-functions.sh
108 %{_var}/opt/opnfv/lib/utility-functions.sh
109 %{_var}/opt/opnfv/lib/python/
110 %{python3_sitelib}/apex/
111 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
112 %{_var}/opt/opnfv/lib/installer/domain.xml
113 %{_sysconfdir}/bash_completion.d/apex
114 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
115 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
116 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
117 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
118 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
119 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
120 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
121 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
122 %{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
123 %{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-noha.yaml
124 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
125 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
126 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
127 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
128 %{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
129 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
130 %{_sysconfdir}/opnfv-apex/network_settings.yaml
131 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
132 %doc %{_docdir}/opnfv/LICENSE.rst
133 %doc %{_docdir}/opnfv/installation-instructions.html
134 %doc %{_docdir}/opnfv/release-notes.rst
135 %doc %{_docdir}/opnfv/release-notes.html
136 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
137 %doc %{_docdir}/opnfv/network_settings.yaml.example
138 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
139 %doc %{_docdir}/opnfv/inventory.yaml.example
140
141 %changelog
142 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
143 - Version update for Danube
144 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
145 - adding bash completion script
146 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
147 - Add clean library.
148 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
149 - Add nosdn fdio scenarios.
150 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
151 - Adding functions.sh files
152 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
153 - Add fdio scenarios.
154 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
155 - Add network_settings_v6.yaml
156 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
157 - Add custom libvirt domain.xml.
158 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
159 - Add performance deployment file
160 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
161 - Fixes python3 dependency.
162 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
163 - Adds dependency for python34-setuptools
164 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
165 - Adds python network setting parsing lib.
166 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
167 - Adds python ip utility lib.
168 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
169 - adding opnfv-util
170 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
171 - Version update for Colorado
172 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
173 - adding dependencies initscripts net-tools iputils iproute iptables
174 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
175 - Adds example inventory file and nosdn scenario
176 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
177 - Updating the installation instructions
178 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
179 - Package Split