Euphrates Docs update w odl scenario name cleanups
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        4.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2 python3-ipmi
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
26 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
37 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
38
39 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
40 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
41 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
42 install config/deploy/os-nosdn-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
43 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
44 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
45 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
46 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
47 install config/deploy/os-nosdn-kvm-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
48 install config/deploy/os-nosdn-kvm-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
49 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
50 install config/deploy/os-odl-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
51 install config/deploy/os-odl-bgpvpn-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
52 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
53 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
54 install config/deploy/os-odl-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
55 install config/deploy/os-odl-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
56 install config/deploy/os-odl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
57 install config/deploy/os-odl-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
58 install config/deploy/os-odl-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-ovs-ha.yaml
59 install config/deploy/os-odl-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-ovs-noha.yaml
60 install config/deploy/os-odl-gluon-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
61 install config/deploy/os-ovn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
62 #install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
63 #install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
64 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
65 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
66 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
67 install config/network/network_settings_vpp.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
68
69
70 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
71 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
72 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
73 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
74 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
75 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
76 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
77 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
78 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
79 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
80 mkdir -p %{buildroot}%{python3_sitelib}/apex/
81 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
82 install lib/python/apex/deploy_settings.py %{buildroot}%{python3_sitelib}/apex/
83 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
84 install lib/python/apex/inventory.py %{buildroot}%{python3_sitelib}/apex/
85 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
86 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
87 install lib/python/apex/clean.py %{buildroot}%{python3_sitelib}/apex/
88 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
89 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
90 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
91 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
92 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
93 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
94 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
95
96 mkdir -p %{buildroot}%{_docdir}/opnfv/
97 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
98 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
99 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
100 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
101 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
102 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
103 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
104 install config/network/network_settings_vpp.yaml %{buildroot}%{_docdir}/opnfv/network_settings_vpp.yaml.example
105 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
106
107 %files
108 %defattr(644, root, root, -)
109 %attr(755,root,root) %{_bindir}/opnfv-deploy
110 %attr(755,root,root) %{_bindir}/opnfv-clean
111 %attr(755,root,root) %{_bindir}/opnfv-util
112 %{_var}/opt/opnfv/lib/common-functions.sh
113 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
114 %{_var}/opt/opnfv/lib/parse-functions.sh
115 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
116 %{_var}/opt/opnfv/lib/undercloud-functions.sh
117 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
118 %{_var}/opt/opnfv/lib/post-install-functions.sh
119 %{_var}/opt/opnfv/lib/utility-functions.sh
120 %{_var}/opt/opnfv/lib/python/
121 %{python3_sitelib}/apex/
122 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
123 %{_var}/opt/opnfv/lib/installer/domain.xml
124 %{_sysconfdir}/bash_completion.d/apex
125 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
126 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
127 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
128 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
129 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
130 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
131 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
132 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
133 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
134 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
135 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
136 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
137 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
138 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
139 %{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
140 %{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
141 %{_sysconfdir}/opnfv-apex/os-odl-ovs-noha.yaml
142 %{_sysconfdir}/opnfv-apex/os-odl-ovs-ha.yaml
143 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
144 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
145 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
146 %{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
147 #%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
148 #%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
149 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
150 %{_sysconfdir}/opnfv-apex/network_settings.yaml
151 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
152 %{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
153 %doc %{_docdir}/opnfv/LICENSE.rst
154 %doc %{_docdir}/opnfv/installation-instructions.html
155 %doc %{_docdir}/opnfv/release-notes.rst
156 %doc %{_docdir}/opnfv/release-notes.html
157 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
158 %doc %{_docdir}/opnfv/network_settings.yaml.example
159 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
160 %doc %{_docdir}/opnfv/network_settings_vpp.yaml.example
161 %doc %{_docdir}/opnfv/inventory.yaml.example
162
163 %changelog
164 * Wed Mar 29 2017 Dan Radez <dradez@redhat.com> - 4.0-9
165 - Remove odl_l2-nofeature scenario file
166 - rename all odl_l3 scenario files to odl
167 * Thu Mar 23 2017 Tim Rozet <trozet@redhat.com> - 4.0-8
168 - Adds os-odl_l3-ovs-ha and noha scenarios
169 * Mon Mar 12 2017 Feng Pan <fpan@redhat.com> - 4.0-7
170 - Add os-nosdn-fdio-ha.yaml
171 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
172 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
173 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
174 - Commenting out ONOS, unsupported in Danube
175 - Adding kvm4nfv files
176 - Adding OVN files
177 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
178 - Add network_settings_vpp.yaml
179 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
180 - change odl_l3-gluon-noha to odl-gluon-noha
181 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
182 - Add odl_l3-gluon-noha config file
183 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
184 - Version update for Danube
185 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
186 - adding bash completion script
187 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
188 - Add clean library.
189 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
190 - Add nosdn fdio scenarios.
191 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
192 - Adding functions.sh files
193 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
194 - Add fdio scenarios.
195 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
196 - Add network_settings_v6.yaml
197 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
198 - Add custom libvirt domain.xml.
199 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
200 - Add performance deployment file
201 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
202 - Fixes python3 dependency.
203 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
204 - Adds dependency for python34-setuptools
205 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
206 - Adds python network setting parsing lib.
207 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
208 - Adds python ip utility lib.
209 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
210 - adding opnfv-util
211 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
212 - Version update for Colorado
213 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
214 - adding dependencies initscripts net-tools iputils iproute iptables
215 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
216 - Adds example inventory file and nosdn scenario
217 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
218 - Updating the installation instructions
219 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
220 - Package Split