Add ODL netvirt VPP support
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        5.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2 python3-ipmi
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
26 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
37 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
38
39 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
40 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
41 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
42 install config/deploy/os-nosdn-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
43 install config/deploy/os-nosdn-ovs_dpdk-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-noha.yaml
44 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
45 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
46 install config/deploy/os-nosdn-ovs_dpdk-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-ha.yaml
47 install config/deploy/os-nosdn-kvm-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
48 install config/deploy/os-nosdn-kvm-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
49 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
50 install config/deploy/os-odl-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
51 install config/deploy/os-odl-bgpvpn-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
52 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
53 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
54 install config/deploy/os-odl-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
55 install config/deploy/os-odl_netvirt-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_netvirt-fdio-noha.yaml
56 install config/deploy/os-odl-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
57 install config/deploy/os-odl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
58 install config/deploy/os-odl-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
59 install config/deploy/os-odl-ovs_dpdk-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-ha.yaml
60 install config/deploy/os-odl-ovs_dpdk-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-noha.yaml
61 install config/deploy/os-odl-gluon-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
62 install config/deploy/os-ovn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
63 #install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
64 #install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
65 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
66 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
67 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
68 install config/network/network_settings_vpp.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
69
70
71 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
72 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
73 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
74 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
75 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
76 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
77 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
78 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
79 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
80 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
81 mkdir -p %{buildroot}%{python3_sitelib}/apex/
82 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
83 install lib/python/apex/deploy_settings.py %{buildroot}%{python3_sitelib}/apex/
84 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
85 install lib/python/apex/inventory.py %{buildroot}%{python3_sitelib}/apex/
86 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
87 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
88 install lib/python/apex/clean.py %{buildroot}%{python3_sitelib}/apex/
89 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
90 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
91 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
92 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
93 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
94 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
95 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
96
97 mkdir -p %{buildroot}%{_docdir}/opnfv/
98 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
99 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
100 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
101 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
102 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
103 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
104 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
105 install config/network/network_settings_vpp.yaml %{buildroot}%{_docdir}/opnfv/network_settings_vpp.yaml.example
106 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
107
108 %files
109 %defattr(644, root, root, -)
110 %attr(755,root,root) %{_bindir}/opnfv-deploy
111 %attr(755,root,root) %{_bindir}/opnfv-clean
112 %attr(755,root,root) %{_bindir}/opnfv-util
113 %{_var}/opt/opnfv/lib/common-functions.sh
114 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
115 %{_var}/opt/opnfv/lib/parse-functions.sh
116 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
117 %{_var}/opt/opnfv/lib/undercloud-functions.sh
118 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
119 %{_var}/opt/opnfv/lib/post-install-functions.sh
120 %{_var}/opt/opnfv/lib/utility-functions.sh
121 %{_var}/opt/opnfv/lib/python/
122 %{python3_sitelib}/apex/
123 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
124 %{_var}/opt/opnfv/lib/installer/domain.xml
125 %{_sysconfdir}/bash_completion.d/apex
126 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
127 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
128 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-ha.yaml
129 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-noha.yaml
130 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
131 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
132 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs_dpdk-ha.yaml
133 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
134 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
135 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
136 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
137 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
138 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
139 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
140 %{_sysconfdir}/opnfv-apex/os-odl-fdio-noha.yaml
141 %{_sysconfdir}/opnfv-apex/os-odl_netvirt-fdio-noha.yaml
142 %{_sysconfdir}/opnfv-apex/os-odl-fdio-ha.yaml
143 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-noha.yaml
144 %{_sysconfdir}/opnfv-apex/os-odl-ovs_dpdk-ha.yaml
145 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-ha.yaml
146 %{_sysconfdir}/opnfv-apex/os-odl-nofeature-noha.yaml
147 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
148 %{_sysconfdir}/opnfv-apex/os-ovn-nofeature-noha.yaml
149 #%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
150 #%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
151 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
152 %{_sysconfdir}/opnfv-apex/network_settings.yaml
153 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
154 %{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
155 %doc %{_docdir}/opnfv/LICENSE.rst
156 %doc %{_docdir}/opnfv/installation-instructions.html
157 %doc %{_docdir}/opnfv/release-notes.rst
158 %doc %{_docdir}/opnfv/release-notes.html
159 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
160 %doc %{_docdir}/opnfv/network_settings.yaml.example
161 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
162 %doc %{_docdir}/opnfv/network_settings_vpp.yaml.example
163 %doc %{_docdir}/opnfv/inventory.yaml.example
164
165 %changelog
166 * Tue Apr 04 2017 Dan Radez <dradez@redhat.com> - 5.0-1
167 - Version update for Euphrates
168 - rename to ovs_dpdk
169 * Wed Mar 29 2017 Dan Radez <dradez@redhat.com> - 4.0-9
170 - Remove odl_l2-nofeature scenario file
171 - rename all odl_l3 scenario files to odl
172 * Thu Mar 23 2017 Tim Rozet <trozet@redhat.com> - 4.0-8
173 - Adds os-odl_l3-ovs-ha and noha scenarios
174 * Mon Mar 12 2017 Feng Pan <fpan@redhat.com> - 4.0-7
175 - Add os-nosdn-fdio-ha.yaml
176 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
177 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
178 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
179 - Commenting out ONOS, unsupported in Danube
180 - Adding kvm4nfv files
181 - Adding OVN files
182 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
183 - Add network_settings_vpp.yaml
184 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
185 - change odl_l3-gluon-noha to odl-gluon-noha
186 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
187 - Add odl_l3-gluon-noha config file
188 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
189 - Version update for Danube
190 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
191 - adding bash completion script
192 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
193 - Add clean library.
194 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
195 - Add nosdn fdio scenarios.
196 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
197 - Adding functions.sh files
198 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
199 - Add fdio scenarios.
200 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
201 - Add network_settings_v6.yaml
202 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
203 - Add custom libvirt domain.xml.
204 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
205 - Add performance deployment file
206 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
207 - Fixes python3 dependency.
208 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
209 - Adds dependency for python34-setuptools
210 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
211 - Adds python network setting parsing lib.
212 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
213 - Adds python ip utility lib.
214 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
215 - adding opnfv-util
216 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
217 - Version update for Colorado
218 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
219 - adding dependencies initscripts net-tools iputils iproute iptables
220 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
221 - Adds example inventory file and nosdn scenario
222 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
223 - Updating the installation instructions
224 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
225 - Package Split