Add support for odl_l3-fdio
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        4.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2 python3-ipmi
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/release/installation/index.rst docs/release/installation/installation-instructions.html
26 rst2html docs/release/release-notes/release-notes.rst docs/release/release-notes/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
37 install build/bash_completion_apex %{buildroot}%{_sysconfdir}/bash_completion.d/apex
38
39 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
40 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
41 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
42 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
43 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
44 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
45 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
46 install config/deploy/os-nosdn-kvm-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
47 install config/deploy/os-nosdn-kvm-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
48 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
49 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
50 install config/deploy/os-odl-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
51 install config/deploy/os-odl-bgpvpn-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
52 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
53 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
54 install config/deploy/os-odl_l3-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-noha.yaml
55 install config/deploy/os-odl_l3-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-ha.yaml
56 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
57 install config/deploy/os-odl-gluon-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
58 #install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
59 #install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
60 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
61 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
62 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
63 install config/network/network_settings_vpp.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
64
65
66 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
67 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
68 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
69 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
70 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
71 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
72 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
73 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
74 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
75 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
76 mkdir -p %{buildroot}%{python3_sitelib}/apex/
77 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
78 install lib/python/apex/deploy_settings.py %{buildroot}%{python3_sitelib}/apex/
79 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
80 install lib/python/apex/inventory.py %{buildroot}%{python3_sitelib}/apex/
81 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
82 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
83 install lib/python/apex/clean.py %{buildroot}%{python3_sitelib}/apex/
84 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
85 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
86 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
87 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
88 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
89 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
90 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
91
92 mkdir -p %{buildroot}%{_docdir}/opnfv/
93 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
94 install docs/release/installation/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
95 install docs/release/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
96 install docs/release/release-notes/release-notes.html %{buildroot}%{_docdir}/opnfv/
97 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
98 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
99 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
100 install config/network/network_settings_vpp.yaml %{buildroot}%{_docdir}/opnfv/network_settings_vpp.yaml.example
101 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
102
103 %files
104 %defattr(644, root, root, -)
105 %attr(755,root,root) %{_bindir}/opnfv-deploy
106 %attr(755,root,root) %{_bindir}/opnfv-clean
107 %attr(755,root,root) %{_bindir}/opnfv-util
108 %{_var}/opt/opnfv/lib/common-functions.sh
109 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
110 %{_var}/opt/opnfv/lib/parse-functions.sh
111 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
112 %{_var}/opt/opnfv/lib/undercloud-functions.sh
113 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
114 %{_var}/opt/opnfv/lib/post-install-functions.sh
115 %{_var}/opt/opnfv/lib/utility-functions.sh
116 %{_var}/opt/opnfv/lib/python/
117 %{python3_sitelib}/apex/
118 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
119 %{_var}/opt/opnfv/lib/installer/domain.xml
120 %{_sysconfdir}/bash_completion.d/apex
121 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
122 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
123 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
124 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
125 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
126 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
127 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-ha.yaml
128 %{_sysconfdir}/opnfv-apex/os-nosdn-kvm-noha.yaml
129 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
130 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
131 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-ha.yaml
132 %{_sysconfdir}/opnfv-apex/os-odl-bgpvpn-noha.yaml
133 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
134 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
135 %{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-noha.yaml
136 %{_sysconfdir}/opnfv-apex/os-odl_l3-fdio-ha.yaml
137 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
138 %{_sysconfdir}/opnfv-apex/os-odl-gluon-noha.yaml
139 #%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
140 #%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
141 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
142 %{_sysconfdir}/opnfv-apex/network_settings.yaml
143 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
144 %{_sysconfdir}/opnfv-apex/network_settings_vpp.yaml
145 %doc %{_docdir}/opnfv/LICENSE.rst
146 %doc %{_docdir}/opnfv/installation-instructions.html
147 %doc %{_docdir}/opnfv/release-notes.rst
148 %doc %{_docdir}/opnfv/release-notes.html
149 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
150 %doc %{_docdir}/opnfv/network_settings.yaml.example
151 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
152 %doc %{_docdir}/opnfv/network_settings_vpp.yaml.example
153 %doc %{_docdir}/opnfv/inventory.yaml.example
154
155 %changelog
156 * Fri Mar 10 2017 Feng Pan <fpan@redhat.com> - 4.0-6
157 - Add os-odl_l3-fdio-noha.yaml and os-odl_l3-fdio-ha.yaml
158 * Wed Mar 08 2017 Dan Radez <dradez@redhat.com> - 4.0-5
159 - Commenting out ONOS, unsupported in Danube
160 - Adding kvm4nfv files
161 * Tue Feb 14 2017 Feng Pan <fpan@redhat.com> - 4.0-4
162 - Add network_settings_vpp.yaml
163 * Fri Feb 3 2017 Nikolas Hermanns <nikolas.hermanns@ericsson.com> - 4.0-3
164 - change odl_l3-gluon-noha to odl-gluon-noha
165 * Thu Feb 2 2017 Feng Pan <fpan@redhat.com> - 4.0-2
166 - Add odl_l3-gluon-noha config file
167 * Wed Nov 2 2016 Dan Radez <dradez@redhat.com> - 4.0-1
168 - Version update for Danube
169 * Fri Sep 16 2016 Dan Radez <dradez@redhat.com> - 3.0-13
170 - adding bash completion script
171 * Tue Aug 30 2016 Tim Rozet <trozet@redhat.com> - 3.0-12
172 - Add clean library.
173 * Mon Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
174 - Add nosdn fdio scenarios.
175 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
176 - Adding functions.sh files
177 * Wed Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
178 - Add fdio scenarios.
179 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
180 - Add network_settings_v6.yaml
181 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
182 - Add custom libvirt domain.xml.
183 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
184 - Add performance deployment file
185 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
186 - Fixes python3 dependency.
187 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
188 - Adds dependency for python34-setuptools
189 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
190 - Adds python network setting parsing lib.
191 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
192 - Adds python ip utility lib.
193 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
194 - adding opnfv-util
195 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
196 - Version update for Colorado
197 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
198 - adding dependencies initscripts net-tools iputils iproute iptables
199 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
200 - Adds example inventory file and nosdn scenario
201 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
202 - Updating the installation instructions
203 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
204 - Package Split