adding tackerclient to the build
[apex.git] / build / rpm_specs / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
26 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
37 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
38 install config/deploy/os-nosdn-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
39 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
40 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
41 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
42 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
43 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
44 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
45 install config/deploy/os-odl_l2-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
46 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
47 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
48 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
49 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
50 install config/deploy/os-onos-sfc-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
51 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
52 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
53 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
54
55
56 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
57 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
58 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
59 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
60 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
61 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
62 install lib/overcloud-deploy-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
63 install lib/post-install-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
64 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
65 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
66 mkdir -p %{buildroot}%{python3_sitelib}/apex/
67 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
68 install lib/python/apex/deploy_env.py %{buildroot}%{python3_sitelib}/apex/
69 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
70 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
71 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
72 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
73 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
74 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
75 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
76 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
77 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
78 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
79
80 mkdir -p %{buildroot}%{_docdir}/opnfv/
81 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
82 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
83 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
84 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
85 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
86 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
87 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
88 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
89
90 %files
91 %defattr(644, root, root, -)
92 %attr(755,root,root) %{_bindir}/opnfv-deploy
93 %attr(755,root,root) %{_bindir}/opnfv-clean
94 %attr(755,root,root) %{_bindir}/opnfv-util
95 %{_var}/opt/opnfv/lib/common-functions.sh
96 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
97 %{_var}/opt/opnfv/lib/parse-functions.sh
98 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
99 %{_var}/opt/opnfv/lib/undercloud-functions.sh
100 %{_var}/opt/opnfv/lib/overcloud-deploy-functions.sh
101 %{_var}/opt/opnfv/lib/post-install-functions.sh
102 %{_var}/opt/opnfv/lib/utility-functions.sh
103 %{_var}/opt/opnfv/lib/python/
104 %{python3_sitelib}/apex/
105 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
106 %{_var}/opt/opnfv/lib/installer/domain.xml
107 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
108 %{_sysconfdir}/opnfv-apex/os-nosdn-fdio-noha.yaml
109 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
110 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
111 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
112 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
113 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
114 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
115 %{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
116 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
117 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
118 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
119 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
120 %{_sysconfdir}/opnfv-apex/os-onos-sfc-ha.yaml
121 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
122 %{_sysconfdir}/opnfv-apex/network_settings.yaml
123 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
124 %doc %{_docdir}/opnfv/LICENSE.rst
125 %doc %{_docdir}/opnfv/installation-instructions.html
126 %doc %{_docdir}/opnfv/release-notes.rst
127 %doc %{_docdir}/opnfv/release-notes.html
128 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
129 %doc %{_docdir}/opnfv/network_settings.yaml.example
130 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
131 %doc %{_docdir}/opnfv/inventory.yaml.example
132
133 %changelog
134 * Thu Aug 1 2016 Tim Rozet <trozet@redhat.com> - 3.0-11
135 - Add nosdn fdio scenarios.
136 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
137 - Adding functions.sh files
138 * Thu Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
139 - Add fdio scenarios.
140 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
141 - Add network_settings_v6.yaml
142 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
143 - Add custom libvirt domain.xml.
144 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
145 - Add performance deployment file
146 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
147 - Fixes python3 dependency.
148 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
149 - Adds dependency for python34-setuptools
150 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
151 - Adds python network setting parsing lib.
152 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
153 - Adds python ip utility lib.
154 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
155 - adding opnfv-util
156 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
157 - Version update for Colorado
158 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
159 - adding dependencies initscripts net-tools iputils iproute iptables
160 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
161 - Adds example inventory file and nosdn scenario
162 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
163 - Updating the installation instructions
164 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
165 - Package Split