3 Summary: OpenStack Networking for VPP
4 Name: python-networking-vpp
6 Release: %{release}%{?git}%{?dist}
9 Group: Applications/Internet
10 Source0: python-networking-vpp.tar.gz
11 Url: https://github.com/openstack/networking-vpp/
16 Vendor: OpenStack <openstack-dev@lists.openstack.org>
17 Packager: Feng Pan <fpan@redhat.com>
20 ML2 Mechanism driver and small control plane for OpenVPP forwarder
24 cat << EOF > %{_builddir}/neutron-vpp-agent.service
26 Description=Networking VPP ML2 Agent
29 ExecStartPre=/usr/bin/systemctl is-active vpp
30 ExecStart=/usr/bin/vpp-agent --config-file /etc/neutron/plugins/ml2/vpp_agent.ini
36 WantedBy=multi-user.target
41 python setup.py install -O1 --root=%{buildroot} --record=INSTALLED_FILES
42 mkdir -p %{buildroot}%{_libdir}/systemd/system
43 install %{_builddir}/neutron-vpp-agent.service %{buildroot}%{_unitdir}
48 %files -f INSTALLED_FILES
50 %attr(644,root,root) %{_unitdir}/neutron-vpp-agent.service