Adding network configuration options
[apex.git] / build / opnfv-apex.spec
1 Name:           opnfv-apex
2 Version:        2.6
3 Release:        %{release}
4 Summary:        Scripts and Disk images for deployment
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  openvswitch qemu-kvm python-docutils
13 Requires:       openvswitch qemu-kvm bridge-utils libguestfs-tools
14
15 %description
16 These files are scripts and disk images used to launch the instack
17 libvirt VM and to load into the instack undercloud machine
18 to deploy an OpenStack overcloud. Installation is done via RDO Manager
19 https://rdoproject.org
20
21 %prep
22 %setup -q
23
24
25 %build
26 rst2html docs/installation-instructions/installation-instructions.rst docs/installation-instructions.html
27 rst2html docs/release-notes/index.rst docs/release-notes.html
28
29 %install
30 mkdir -p %{buildroot}%{_bindir}/
31 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
32 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
33
34 mkdir -p %{buildroot}%{_var}/opt/opnfv/stack/
35 mkdir -p %{buildroot}%{_var}/opt/opnfv/nics/
36
37 install build/instack.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
38 install build/instack.xml %{buildroot}%{_var}/opt/opnfv/
39 install build/baremetalbrbm_brbm1_*.xml %{buildroot}%{_var}/opt/opnfv/
40 install build/brbm-net.xml %{buildroot}%{_var}/opt/opnfv/
41 install build/brbm1-net.xml %{buildroot}%{_var}/opt/opnfv/
42 install build/default-pool.xml %{buildroot}%{_var}/opt/opnfv/
43 install build/network-environment.yaml %{buildroot}%{_var}/opt/opnfv/
44 install build/nics/controller.yaml %{buildroot}%{_var}/opt/opnfv/nics/
45 install build/nics/compute.yaml %{buildroot}%{_var}/opt/opnfv/nics/
46 install build/opendaylight-puppet-neutron.patch %{buildroot}%{_var}/opt/opnfv/
47 install build/opendaylight-tripleo-heat-templates.patch %{buildroot}%{_var}/opt/opnfv/
48
49 install build/instackenv-virt.json %{buildroot}%{_var}/opt/opnfv/
50 install build/instackenv.json.example %{buildroot}%{_var}/opt/opnfv/
51 install build/stack/overcloud-full.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
52
53 mkdir -p %{buildroot}%{_docdir}/opnfv/
54 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
55 install docs/installation-instructions/index.rst %{buildroot}%{_docdir}/opnfv/installation-instructions.rst
56 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
57 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
58 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
59 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
60
61 %files
62 %{_bindir}/opnfv-deploy
63 %{_bindir}/opnfv-clean
64 %{_var}/opt/opnfv/stack/instack.qcow2
65 %{_var}/opt/opnfv/instack.xml
66 %{_var}/opt/opnfv/baremetalbrbm_brbm1_*.xml
67 %{_var}/opt/opnfv/brbm-net.xml
68 %{_var}/opt/opnfv/brbm1-net.xml
69 %{_var}/opt/opnfv/default-pool.xml
70 %{_var}/opt/opnfv/network-environment.yaml
71 %{_var}/opt/opnfv/nics/controller.yaml
72 %{_var}/opt/opnfv/nics/compute.yaml
73 %{_var}/opt/opnfv/opendaylight-puppet-neutron.patch
74 %{_var}/opt/opnfv/opendaylight-tripleo-heat-templates.patch
75 %{_var}/opt/opnfv/instackenv-virt.json
76 %{_var}/opt/opnfv/instackenv.json.example
77 %{_var}/opt/opnfv/stack/overcloud-full.qcow2
78 %doc %{_docdir}/opnfv/LICENSE.rst
79 %doc %{_docdir}/opnfv/installation-instructions.rst
80 %doc %{_docdir}/opnfv/installation-instructions.html
81 %doc %{_docdir}/opnfv/release-notes.rst
82 %doc %{_docdir}/opnfv/release-notes.html
83 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
84
85
86 %changelog
87 * Tue Dec 15 2015 Dan Radez <dradez@redhat.com> - 2.6-1
88 - Added deploy settings for flat network config
89 * Wed Dec 09 2015 Dan Radez <dradez@redhat.com> - 2.5-1
90 - Updating the OpenDaylight Patch
91 * Fri Dec 05 2015 Dan Radez <dradez@redhat.com> - 2.4-1
92 - Removing glance images
93 * Fri Nov 20 2015 Dan Radez <dradez@redhat.com> - 2.3-1
94 - Adding documentation
95 * Thu Nov 12 2015 Dan Radez <dradez@redhat.com> - 2.2-1
96 - OpenDaylight and Network Isolation support
97 * Wed Oct 21 2015 Dan Radez <dradez@redhat.com> - 2.1-1
98 - Initial deployment success using RPM packaging
99 * Fri Sep 25 2015 Dan Radez <dradez@redhat.com> - 2.0-1
100 - Migrated to RDO Manager
101 * Fri Apr 24 2015 Dan Radez <dradez@redhat.com> - 0.1-1
102 - Initial Packaging