cb9f7705b9ab5e018b3c0f4bab5119dc60fc78b7
[apex.git] / build / opnfv-apex.spec
1 Name:           opnfv-apex
2 Version:        2.7
3 Release:        %{release}
4 Summary:        Scripts and Disk images for deployment
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  openvswitch qemu-kvm python-docutils
13 Requires:       openvswitch qemu-kvm bridge-utils libguestfs-tools
14
15 %description
16 These files are scripts and disk images used to launch the instack
17 libvirt VM and to load into the instack undercloud machine
18 to deploy an OpenStack overcloud. Installation is done via RDO Manager
19 https://rdoproject.org
20
21 %prep
22 %setup -q
23
24
25 %build
26 rst2html docs/installation-instructions/installation-instructions.rst docs/installation-instructions.html
27 rst2html docs/release-notes/index.rst docs/release-notes.html
28
29 %install
30 mkdir -p %{buildroot}%{_bindir}/
31 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
32 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
33
34 mkdir -p %{buildroot}%{_var}/opt/opnfv/stack/
35 mkdir -p %{buildroot}%{_var}/opt/opnfv/nics/
36 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
37
38 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
39 install build/instack.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
40 install build/instack.xml %{buildroot}%{_var}/opt/opnfv/
41 install build/baremetalbrbm_brbm1_brbm2_brbm3_*.xml %{buildroot}%{_var}/opt/opnfv/
42 install build/brbm-net.xml %{buildroot}%{_var}/opt/opnfv/
43 install build/brbm1-net.xml %{buildroot}%{_var}/opt/opnfv/
44 install build/brbm2-net.xml %{buildroot}%{_var}/opt/opnfv/
45 install build/brbm3-net.xml %{buildroot}%{_var}/opt/opnfv/
46 install build/default-pool.xml %{buildroot}%{_var}/opt/opnfv/
47 install build/network-environment.yaml %{buildroot}%{_var}/opt/opnfv/
48 install build/nics/controller.yaml %{buildroot}%{_var}/opt/opnfv/nics/
49 install build/nics/compute.yaml %{buildroot}%{_var}/opt/opnfv/nics/
50
51 install build/instackenv-virt.json %{buildroot}%{_var}/opt/opnfv/
52 install build/instackenv.json.example %{buildroot}%{_var}/opt/opnfv/
53 install build/stack/overcloud-full.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
54
55 mkdir -p %{buildroot}%{_docdir}/opnfv/
56 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
57 install docs/installation-instructions/index.rst %{buildroot}%{_docdir}/opnfv/installation-instructions.rst
58 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
59 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
60 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
61 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
62 install config/deploy/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
63
64 %files
65 %{_bindir}/opnfv-deploy
66 %{_bindir}/opnfv-clean
67 %{_var}/opt/opnfv/lib/common-functions.sh
68 %{_var}/opt/opnfv/stack/instack.qcow2
69 %{_var}/opt/opnfv/instack.xml
70 %{_var}/opt/opnfv/baremetalbrbm_brbm1_brbm2_brbm3_*.xml
71 %{_var}/opt/opnfv/brbm-net.xml
72 %{_var}/opt/opnfv/brbm1-net.xml
73 %{_var}/opt/opnfv/brbm2-net.xml
74 %{_var}/opt/opnfv/brbm3-net.xml
75 %{_var}/opt/opnfv/default-pool.xml
76 %{_var}/opt/opnfv/network-environment.yaml
77 %{_var}/opt/opnfv/nics/controller.yaml
78 %{_var}/opt/opnfv/nics/compute.yaml
79 %{_var}/opt/opnfv/instackenv-virt.json
80 %{_var}/opt/opnfv/instackenv.json.example
81 %{_var}/opt/opnfv/stack/overcloud-full.qcow2
82 %doc %{_docdir}/opnfv/LICENSE.rst
83 %doc %{_docdir}/opnfv/installation-instructions.rst
84 %doc %{_docdir}/opnfv/installation-instructions.html
85 %doc %{_docdir}/opnfv/release-notes.rst
86 %doc %{_docdir}/opnfv/release-notes.html
87 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
88 %doc %{_docdir}/opnfv/network_settings.yaml.example
89
90 %changelog
91 * Tue Dec 20 2015 Tim Rozet <trozet@redhat.com> - 2.7-1
92 - Modifies networks to include OPNFV private/storage networks
93 * Tue Dec 15 2015 Dan Radez <dradez@redhat.com> - 2.6-1
94 - Added deploy settings for flat network config
95 - cleaned up files that don't need to be in the rpm
96 * Wed Dec 09 2015 Dan Radez <dradez@redhat.com> - 2.5-1
97 - Updating the OpenDaylight Patch
98 * Fri Dec 05 2015 Dan Radez <dradez@redhat.com> - 2.4-1
99 - Removing glance images
100 * Fri Nov 20 2015 Dan Radez <dradez@redhat.com> - 2.3-1
101 - Adding documentation
102 * Thu Nov 12 2015 Dan Radez <dradez@redhat.com> - 2.2-1
103 - OpenDaylight and Network Isolation support
104 * Wed Oct 21 2015 Dan Radez <dradez@redhat.com> - 2.1-1
105 - Initial deployment success using RPM packaging
106 * Fri Sep 25 2015 Dan Radez <dradez@redhat.com> - 2.0-1
107 - Migrated to RDO Manager
108 * Fri Apr 24 2015 Dan Radez <dradez@redhat.com> - 0.1-1
109 - Initial Packaging