Renaming Instack to Undercloud
[apex.git] / build / opnfv-apex-undercloud.spec
1 Name:           opnfv-apex-undercloud
2 Version:        2.1
3 Release:        %{release}
4 Summary:        Scripts and Disk images to launch the Undercloud for OPNFV Apex
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-undercloud.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  openvswitch libvirt qemu-kvm python-docutils
13 Requires:       openvswitch libvirt qemu-kvm bridge-utils libguestfs-tools
14
15 %description
16 Scripts and Disk images to launch the Undercloud for OPNFV Apex
17 https://wiki.opnfv.org/apex
18
19 %prep
20 %setup -q
21
22 %install
23 mkdir -p %{buildroot}%{_var}/opt/opnfv/images/
24 mkdir -p %{buildroot}%{_var}/opt/opnfv/nics/
25
26 install build/undercloud.qcow2 %{buildroot}%{_var}/opt/opnfv/images/
27 install build/network-environment.yaml %{buildroot}%{_var}/opt/opnfv/
28 install build/nics/controller.yaml %{buildroot}%{_var}/opt/opnfv/nics/
29 install build/nics/compute.yaml %{buildroot}%{_var}/opt/opnfv/nics/
30 install build/nics/controller_private.yaml %{buildroot}%{_var}/opt/opnfv/nics/
31 install build/nics/compute_private.yaml %{buildroot}%{_var}/opt/opnfv/nics/
32 install build/nics/controller_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
33 install build/nics/compute_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
34 install build/nics/controller_private_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
35 install build/nics/compute_private_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
36 install build/nics/compute_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
37 install build/nics/compute_private_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
38 install build/nics/compute_storage_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
39 install build/nics/compute_private_storage_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
40 install build/nics/compute_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
41 install build/nics/compute_private_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
42 install build/nics/compute_storage_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
43 install build/nics/compute_private_storage_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
44 install build/nics/compute_br-ex_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
45 install build/nics/compute_private_br-ex_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
46 install build/nics/compute_storage_br-ex_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
47 install build/nics/compute_private_storage_br-ex_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
48
49 %files
50 %defattr(644, root, root, -)
51 %{_var}/opt/opnfv/images/undercloud.qcow2
52 %{_var}/opt/opnfv/network-environment.yaml
53 %{_var}/opt/opnfv/nics/controller.yaml
54 %{_var}/opt/opnfv/nics/compute.yaml
55 %{_var}/opt/opnfv/nics/controller_private.yaml
56 %{_var}/opt/opnfv/nics/compute_private.yaml
57 %{_var}/opt/opnfv/nics/controller_storage.yaml
58 %{_var}/opt/opnfv/nics/compute_storage.yaml
59 %{_var}/opt/opnfv/nics/controller_private_storage.yaml
60 %{_var}/opt/opnfv/nics/compute_private_storage.yaml
61 %{_var}/opt/opnfv/nics/compute_br-ex.yaml
62 %{_var}/opt/opnfv/nics/compute_private_br-ex.yaml
63 %{_var}/opt/opnfv/nics/compute_storage_br-ex.yaml
64 %{_var}/opt/opnfv/nics/compute_private_storage_br-ex.yaml
65 %{_var}/opt/opnfv/nics/compute_no-public-ip.yaml
66 %{_var}/opt/opnfv/nics/compute_private_no-public-ip.yaml
67 %{_var}/opt/opnfv/nics/compute_storage_no-public-ip.yaml
68 %{_var}/opt/opnfv/nics/compute_private_storage_no-public-ip.yaml
69 %{_var}/opt/opnfv/nics/compute_br-ex_no-public-ip.yaml
70 %{_var}/opt/opnfv/nics/compute_private_br-ex_no-public-ip.yaml
71 %{_var}/opt/opnfv/nics/compute_storage_br-ex_no-public-ip.yaml
72 %{_var}/opt/opnfv/nics/compute_private_storage_br-ex_no-public-ip.yaml
73
74 %changelog
75 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-1
76 - Package Split