Fixes ONOS external network
[apex.git] / build / opnfv-apex-undercloud.spec
1 Name:           opnfv-apex-undercloud
2 Version:        2.1
3 Release:        %{release}
4 Summary:        Scripts and Disk images to launch Instack Undercloud for OPNFV Apex
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-undercloud.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  openvswitch qemu-kvm python-docutils
13 Requires:       openvswitch qemu-kvm bridge-utils libguestfs-tools
14
15 %description
16 Scripts and Disk images to launch Instack Undercloud for OPNFV Apex
17 https://wiki.opnfv.org/apex
18
19 %prep
20 %setup -q
21
22 %install
23 mkdir -p %{buildroot}%{_var}/opt/opnfv/stack/
24 mkdir -p %{buildroot}%{_var}/opt/opnfv/nics/
25
26 install build/instack.qcow2 %{buildroot}%{_var}/opt/opnfv/stack/
27 install build/instack.xml %{buildroot}%{_var}/opt/opnfv/
28 install build/baremetalbrbm_brbm1_brbm2_brbm3_*.xml %{buildroot}%{_var}/opt/opnfv/
29 install build/brbm-net.xml %{buildroot}%{_var}/opt/opnfv/
30 install build/brbm1-net.xml %{buildroot}%{_var}/opt/opnfv/
31 install build/brbm2-net.xml %{buildroot}%{_var}/opt/opnfv/
32 install build/brbm3-net.xml %{buildroot}%{_var}/opt/opnfv/
33 install build/default-pool.xml %{buildroot}%{_var}/opt/opnfv/
34 install build/network-environment.yaml %{buildroot}%{_var}/opt/opnfv/
35 install build/nics/controller.yaml %{buildroot}%{_var}/opt/opnfv/nics/
36 install build/nics/compute.yaml %{buildroot}%{_var}/opt/opnfv/nics/
37 install build/nics/controller_private.yaml %{buildroot}%{_var}/opt/opnfv/nics/
38 install build/nics/compute_private.yaml %{buildroot}%{_var}/opt/opnfv/nics/
39 install build/nics/controller_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
40 install build/nics/compute_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
41 install build/nics/controller_private_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
42 install build/nics/compute_private_storage.yaml %{buildroot}%{_var}/opt/opnfv/nics/
43 install build/nics/compute_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
44 install build/nics/compute_private_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
45 install build/nics/compute_storage_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
46 install build/nics/compute_private_storage_br-ex.yaml %{buildroot}%{_var}/opt/opnfv/nics/
47 install build/nics/compute_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
48 install build/nics/compute_private_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
49 install build/nics/compute_storage_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
50 install build/nics/compute_private_storage_no-public-ip.yaml %{buildroot}%{_var}/opt/opnfv/nics/
51 install build/instackenv-virt.json %{buildroot}%{_var}/opt/opnfv/
52 install build/instackenv.json.example %{buildroot}%{_var}/opt/opnfv/
53
54 %files
55 %defattr(644, root, root, -)
56 %{_var}/opt/opnfv/stack/instack.qcow2
57 %{_var}/opt/opnfv/instack.xml
58 %{_var}/opt/opnfv/baremetalbrbm_brbm1_brbm2_brbm3_*.xml
59 %{_var}/opt/opnfv/brbm-net.xml
60 %{_var}/opt/opnfv/brbm1-net.xml
61 %{_var}/opt/opnfv/brbm2-net.xml
62 %{_var}/opt/opnfv/brbm3-net.xml
63 %{_var}/opt/opnfv/default-pool.xml
64 %{_var}/opt/opnfv/network-environment.yaml
65 %{_var}/opt/opnfv/nics/controller.yaml
66 %{_var}/opt/opnfv/nics/compute.yaml
67 %{_var}/opt/opnfv/nics/controller_private.yaml
68 %{_var}/opt/opnfv/nics/compute_private.yaml
69 %{_var}/opt/opnfv/nics/controller_storage.yaml
70 %{_var}/opt/opnfv/nics/compute_storage.yaml
71 %{_var}/opt/opnfv/nics/controller_private_storage.yaml
72 %{_var}/opt/opnfv/nics/compute_private_storage.yaml
73 %{_var}/opt/opnfv/nics/compute_br-ex.yaml
74 %{_var}/opt/opnfv/nics/compute_private_br-ex.yaml
75 %{_var}/opt/opnfv/nics/compute_storage_br-ex.yaml
76 %{_var}/opt/opnfv/nics/compute_private_storage_br-ex.yaml
77 %{_var}/opt/opnfv/nics/compute_no-public-ip.yaml
78 %{_var}/opt/opnfv/nics/compute_private_no-public-ip.yaml
79 %{_var}/opt/opnfv/nics/compute_storage_no-public-ip.yaml
80 %{_var}/opt/opnfv/nics/compute_private_storage_no-public-ip.yaml
81 %{_var}/opt/opnfv/instackenv-virt.json
82 %{_var}/opt/opnfv/instackenv.json.example
83
84 %changelog
85 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-1
86 - Package Split