Merge "Fix performance option handling"
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python34-setuptools
15
16 %description
17 Scripts for OPNFV deployment using RDO Manager
18 https://wiki.opnfv.org/apex
19
20 %prep
21 %setup -q
22
23 %build
24 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
25 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
26
27 %global __python %{__python3}
28
29 %install
30 mkdir -p %{buildroot}%{_bindir}/
31 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
32 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
33 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
34
35 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
36 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
37 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
38 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
39 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
40 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
41 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
42 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
43 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
44 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
45
46 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
47 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
48 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
49 install lib/python/apex-python-utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
50 mkdir -p %{buildroot}%{python3_sitelib}/apex/
51 install lib/python/apex/ %{buildroot}%{python3_sitelib}/apex/
52 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
53 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
54
55 mkdir -p %{buildroot}%{_docdir}/opnfv/
56 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
57 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
58 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
59 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
60 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
61 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
62 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
63
64 %files
65 %defattr(644, root, root, -)
66 %attr(755,root,root) %{_bindir}/opnfv-deploy
67 %attr(755,root,root) %{_bindir}/opnfv-clean
68 %attr(755,root,root) %{_bindir}/opnfv-util
69 %{_var}/opt/opnfv/lib/common-functions.sh
70 %{_var}/opt/opnfv/lib/utility-functions.sh
71 %{_var}/opt/opnfv/lib/python/
72 %{python3_sitelib}/apex/
73 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
74 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
75 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
76 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
77 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
78 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
79 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
80 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
81 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
82 %{_sysconfdir}/opnfv-apex/network_settings.yaml
83 %doc %{_docdir}/opnfv/LICENSE.rst
84 %doc %{_docdir}/opnfv/installation-instructions.html
85 %doc %{_docdir}/opnfv/release-notes.rst
86 %doc %{_docdir}/opnfv/release-notes.html
87 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
88 %doc %{_docdir}/opnfv/network_settings.yaml.example
89 %doc %{_docdir}/opnfv/inventory.yaml.example
90
91 %changelog
92 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
93 - Add performance deployment file
94 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
95 - Fixes python3 dependency.
96 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
97 - Adds dependency for python34-setuptools
98 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
99 - Adds python network setting parsing lib.
100 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
101 - Adds python ip utility lib.
102 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
103 - adding opnfv-util
104 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
105 - Version update for Colorado
106 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
107 - adding dependencies initscripts net-tools iputils iproute iptables
108 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
109 - Adds example inventory file and nosdn scenario
110 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
111 - Updating the installation instructions
112 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
113 - Package Split