Add python parsing library for network settings file.
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml
15
16 %description
17 Scripts for OPNFV deployment using RDO Manager
18 https://wiki.opnfv.org/apex
19
20 %prep
21 %setup -q
22
23 %build
24 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
25 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
26
27 %install
28 mkdir -p %{buildroot}%{_bindir}/
29 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
30 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
31 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
32
33 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
34 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
35 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
36 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
37 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
38 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
39 install config/deploy/os-opencontrail-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
40 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
41
42 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
43 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
44 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
45 install lib/python/apex-python-utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
46 mkdir -p %{buildroot}%{python3_sitelib}/apex/
47 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
48 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
49 install lib/python/apex/net_env.py %{buildroot}%{python3_sitelib}/apex/
50 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
51 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
52
53 mkdir -p %{buildroot}%{_docdir}/opnfv/
54 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
55 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
56 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
57 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
58 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
59 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
60 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
61
62 %files
63 %defattr(644, root, root, -)
64 %attr(755,root,root) %{_bindir}/opnfv-deploy
65 %attr(755,root,root) %{_bindir}/opnfv-clean
66 %attr(755,root,root) %{_bindir}/opnfv-util
67 %{_var}/opt/opnfv/lib/common-functions.sh
68 %{_var}/opt/opnfv/lib/utility-functions.sh
69 %{_var}/opt/opnfv/lib/python/apex-python-utils.py
70 %{_var}/opt/opnfv/lib/python/apex-python-utils.pyo
71 %{_var}/opt/opnfv/lib/python/apex-python-utils.pyc
72 %{python3_sitelib}/apex/ip_utils.py
73 %{python3_sitelib}/apex/net_env.py
74 %{python3_sitelib}/apex/__init__.py
75 %{python3_sitelib}/apex/__pycache__/*
76 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
77 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
78 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
79 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
80 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
81 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
82 %{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
83 %{_sysconfdir}/opnfv-apex/network_settings.yaml
84 %doc %{_docdir}/opnfv/LICENSE.rst
85 %doc %{_docdir}/opnfv/installation-instructions.html
86 %doc %{_docdir}/opnfv/release-notes.rst
87 %doc %{_docdir}/opnfv/release-notes.html
88 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
89 %doc %{_docdir}/opnfv/network_settings.yaml.example
90 %doc %{_docdir}/opnfv/inventory.yaml.example
91
92 %changelog
93 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
94 - Adds python network setting parsing lib.
95 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
96 - Adds python ip utility lib.
97 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
98 - adding opnfv-util
99 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
100 - Version update for Colorado
101 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
102 - adding dependencies initscripts net-tools iputils iproute iptables
103 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
104 - Adds example inventory file and nosdn scenario
105 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
106 - Updating the installation instructions
107 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
108 - Package Split