Adds python IP utility library
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34
15
16 %description
17 Scripts for OPNFV deployment using RDO Manager
18 https://wiki.opnfv.org/apex
19
20 %prep
21 %setup -q
22
23 %build
24 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
25 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
26
27 %install
28 mkdir -p %{buildroot}%{_bindir}/
29 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
30 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
31 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
32
33 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
34 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
35 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
36 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
37 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
38 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
39 install config/deploy/os-opencontrail-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
40 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
41
42 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
43 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
44 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
45 mkdir -p %{buildroot}%{python3_sitelib}/apex/
46 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
47 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
48 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
49 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
50
51 mkdir -p %{buildroot}%{_docdir}/opnfv/
52 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
53 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
54 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
55 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
56 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
57 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
58 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
59
60 %files
61 %defattr(644, root, root, -)
62 %attr(755,root,root) %{_bindir}/opnfv-deploy
63 %attr(755,root,root) %{_bindir}/opnfv-clean
64 %attr(755,root,root) %{_bindir}/opnfv-util
65 %{_var}/opt/opnfv/lib/common-functions.sh
66 %{_var}/opt/opnfv/lib/utility-functions.sh
67 %{python3_sitelib}/apex/ip_utils.py
68 %{python3_sitelib}/apex/__init__.py
69 %{python3_sitelib}/apex/__pycache__/*
70 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
71 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
72 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
73 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
74 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
75 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
76 %{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
77 %{_sysconfdir}/opnfv-apex/network_settings.yaml
78 %doc %{_docdir}/opnfv/LICENSE.rst
79 %doc %{_docdir}/opnfv/installation-instructions.html
80 %doc %{_docdir}/opnfv/release-notes.rst
81 %doc %{_docdir}/opnfv/release-notes.html
82 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
83 %doc %{_docdir}/opnfv/network_settings.yaml.example
84 %doc %{_docdir}/opnfv/inventory.yaml.example
85
86 %changelog
87 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
88 - Adds python ip utility lib.
89 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
90 - adding opnfv-util
91 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
92 - Version update for Colorado
93 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
94 - adding dependencies initscripts net-tools iputils iproute iptables
95 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
96 - Adds example inventory file and nosdn scenario
97 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
98 - Updating the installation instructions
99 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
100 - Package Split