Splitting out deploy.sh undercloud to functions file
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2
15 Requires:       ipxe-roms-qemu >= 20160127-1
16
17 %description
18 Scripts for OPNFV deployment using RDO Manager
19 https://wiki.opnfv.org/apex
20
21 %prep
22 %setup -q
23
24 %build
25 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
26 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
27
28 %global __python %{__python3}
29
30 %install
31 mkdir -p %{buildroot}%{_bindir}/
32 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
33 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
34 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
35
36 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
37 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
38 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
39 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
40 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
41 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
42 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
43 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
44 install config/deploy/os-odl_l2-fdio-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
45 install config/deploy/os-odl_l2-fdio-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
46 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
47 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
48 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
49 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
50 install config/network/network_settings_v6.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
51
52
53 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
54 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
55 install lib/configure-deps-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
56 install lib/parse-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
57 install lib/virtual-setup-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
58 install lib/undercloud-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
59 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
60 install lib/python/apex_python_utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
61 mkdir -p %{buildroot}%{python3_sitelib}/apex/
62 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
63 install lib/python/apex/deploy_env.py %{buildroot}%{python3_sitelib}/apex/
64 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
65 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
66 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
67 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
68 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
69 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
70 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
71 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
72 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
73 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
74
75 mkdir -p %{buildroot}%{_docdir}/opnfv/
76 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
77 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
78 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
79 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
80 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
81 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
82 install config/network/network_settings_v6.yaml %{buildroot}%{_docdir}/opnfv/network_settings_v6.yaml.example
83 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
84
85 %files
86 %defattr(644, root, root, -)
87 %attr(755,root,root) %{_bindir}/opnfv-deploy
88 %attr(755,root,root) %{_bindir}/opnfv-clean
89 %attr(755,root,root) %{_bindir}/opnfv-util
90 %{_var}/opt/opnfv/lib/common-functions.sh
91 %{_var}/opt/opnfv/lib/configure-deps-functions.sh
92 %{_var}/opt/opnfv/lib/parse-functions.sh
93 %{_var}/opt/opnfv/lib/virtual-setup-functions.sh
94 %{_var}/opt/opnfv/lib/undercloud-functions.sh
95 %{_var}/opt/opnfv/lib/utility-functions.sh
96 %{_var}/opt/opnfv/lib/python/
97 %{python3_sitelib}/apex/
98 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
99 %{_var}/opt/opnfv/lib/installer/domain.xml
100 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
101 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
102 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
103 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
104 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
105 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
106 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
107 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-noha.yaml
108 %{_sysconfdir}/opnfv-apex/os-odl_l2-fdio-ha.yaml
109 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
110 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
111 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
112 %{_sysconfdir}/opnfv-apex/network_settings.yaml
113 %{_sysconfdir}/opnfv-apex/network_settings_v6.yaml
114 %doc %{_docdir}/opnfv/LICENSE.rst
115 %doc %{_docdir}/opnfv/installation-instructions.html
116 %doc %{_docdir}/opnfv/release-notes.rst
117 %doc %{_docdir}/opnfv/release-notes.html
118 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
119 %doc %{_docdir}/opnfv/network_settings.yaml.example
120 %doc %{_docdir}/opnfv/network_settings_v6.yaml.example
121 %doc %{_docdir}/opnfv/inventory.yaml.example
122
123 %changelog
124 * Tue Jul 5 2016 Dan Radez <dradez@redhat.com> - 3.0-10
125 - Adding functions.sh files
126 * Thu Jun 15 2016 Tim Rozet <trozet@redhat.com> - 3.0-9
127 - Add fdio scenarios.
128 * Tue Jun 14 2016 Feng Pan <fpan@redhat.com> - 3.0-8
129 - Add network_settings_v6.yaml
130 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
131 - Add custom libvirt domain.xml.
132 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
133 - Add performance deployment file
134 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
135 - Fixes python3 dependency.
136 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
137 - Adds dependency for python34-setuptools
138 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
139 - Adds python network setting parsing lib.
140 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
141 - Adds python ip utility lib.
142 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
143 - adding opnfv-util
144 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
145 - Version update for Colorado
146 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
147 - adding dependencies initscripts net-tools iputils iproute iptables
148 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
149 - Adds example inventory file and nosdn scenario
150 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
151 - Updating the installation instructions
152 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
153 - Package Split