Fixes vpn scenario to proper naming convention
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        2.2
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  openvswitch qemu-kvm python-docutils
13 Requires:       opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14
15 %description
16 Scripts for OPNFV deployment using RDO Manager
17 https://wiki.opnfv.org/apex
18
19 %prep
20 %setup -q
21
22 %build
23 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
24 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
25
26 %install
27 mkdir -p %{buildroot}%{_bindir}/
28 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
29 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
30
31 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
32 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
33 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
34 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
35 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
36 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
37 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
38 install config/deploy/os-opencontrail-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
39 install config/deploy/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
40
41 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
42 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
43 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
44 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
45
46 mkdir -p %{buildroot}%{_docdir}/opnfv/
47 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
48 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
49 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
50 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
51 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
52 install config/deploy/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
53 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
54
55 %files
56 %defattr(644, root, root, -)
57 %attr(755,root,root) %{_bindir}/opnfv-deploy
58 %attr(755,root,root) %{_bindir}/opnfv-clean
59 %{_var}/opt/opnfv/lib/common-functions.sh
60 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
61 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
62 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
63 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
64 %{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
65 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
66 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
67 %{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
68 %{_sysconfdir}/opnfv-apex/network_settings.yaml
69 %doc %{_docdir}/opnfv/LICENSE.rst
70 %doc %{_docdir}/opnfv/installation-instructions.html
71 %doc %{_docdir}/opnfv/release-notes.rst
72 %doc %{_docdir}/opnfv/release-notes.html
73 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
74 %doc %{_docdir}/opnfv/network_settings.yaml.example
75 %doc %{_docdir}/opnfv/inventory.yaml.example
76
77 %changelog
78 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
79 - Brahmaputra SR1
80 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
81 - Adds example inventory file and nosdn scenario
82 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
83 - Updating the installation instructions
84 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
85 - Package Split