d1f64d7c1972fc471ad4832cc688b1a3332dbdce
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        2.2
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  openvswitch qemu-kvm python-docutils
13 Requires:       opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables
15
16 %description
17 Scripts for OPNFV deployment using RDO Manager
18 https://wiki.opnfv.org/apex
19
20 %prep
21 %setup -q
22
23 %build
24 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
25 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
26
27 %install
28 mkdir -p %{buildroot}%{_bindir}/
29 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
30 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
31 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
32
33 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
34 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
35 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
36 install config/deploy/os-odl_l2-bgpvpn-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
37 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
38 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
39 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
40 install config/deploy/os-opencontrail-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
41 install config/deploy/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
42
43 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
44 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
45 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
46 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
47 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
48
49 mkdir -p %{buildroot}%{_docdir}/opnfv/
50 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
51 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
52 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
53 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
54 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
55 install config/deploy/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
56 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
57
58 %files
59 %defattr(644, root, root, -)
60 %attr(755,root,root) %{_bindir}/opnfv-deploy
61 %attr(755,root,root) %{_bindir}/opnfv-clean
62 %attr(755,root,root) %{_bindir}/opnfv-util
63 %{_var}/opt/opnfv/lib/common-functions.sh
64 %{_var}/opt/opnfv/lib/utility-functions.sh
65 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
66 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
67 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
68 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
69 %{_sysconfdir}/opnfv-apex/os-odl_l2-bgpvpn-ha.yaml
70 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
71 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
72 %{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
73 %{_sysconfdir}/opnfv-apex/network_settings.yaml
74 %doc %{_docdir}/opnfv/LICENSE.rst
75 %doc %{_docdir}/opnfv/installation-instructions.html
76 %doc %{_docdir}/opnfv/release-notes.rst
77 %doc %{_docdir}/opnfv/release-notes.html
78 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
79 %doc %{_docdir}/opnfv/network_settings.yaml.example
80 %doc %{_docdir}/opnfv/inventory.yaml.example
81
82 %changelog
83 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 2.2-1
84 - adding opnfv-util
85 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
86 - Brahmaputra SR1
87 - adding dependencies initscripts net-tools iputils iproute iptables
88 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
89 - Adds example inventory file and nosdn scenario
90 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
91 - Updating the installation instructions
92 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
93 - Package Split