Merge changes from topics 'c_doc_update', 'detached_cleanup'
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python3-jinja2
15
16 %description
17 Scripts for OPNFV deployment using RDO Manager
18 https://wiki.opnfv.org/apex
19
20 %prep
21 %setup -q
22
23 %build
24 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
25 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
26
27 %global __python %{__python3}
28
29 %install
30 mkdir -p %{buildroot}%{_bindir}/
31 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
32 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
33 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
34
35 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
36 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
37 install config/deploy/os-nosdn-ovs-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
38 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
39 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
40 install config/deploy/os-nosdn-ovs-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
41 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
42 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
43 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
44 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
45 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
46 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
47
48 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
49 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
50 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
51 install lib/python/apex-python-utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
52 mkdir -p %{buildroot}%{python3_sitelib}/apex/
53 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
54 install lib/python/apex/deploy_env.py %{buildroot}%{python3_sitelib}/apex/
55 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
56 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
57 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
58 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
59 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
60 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
61 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
62 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
63 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
64 install lib/installer/domain.xml %{buildroot}%{_var}/opt/opnfv/lib/installer/
65
66 mkdir -p %{buildroot}%{_docdir}/opnfv/
67 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
68 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
69 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
70 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
71 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
72 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
73 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
74
75 %files
76 %defattr(644, root, root, -)
77 %attr(755,root,root) %{_bindir}/opnfv-deploy
78 %attr(755,root,root) %{_bindir}/opnfv-clean
79 %attr(755,root,root) %{_bindir}/opnfv-util
80 %{_var}/opt/opnfv/lib/common-functions.sh
81 %{_var}/opt/opnfv/lib/utility-functions.sh
82 %{_var}/opt/opnfv/lib/python/
83 %{python3_sitelib}/apex/
84 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
85 %{_var}/opt/opnfv/lib/installer/domain.xml
86 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
87 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-noha.yaml
88 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
89 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
90 %{_sysconfdir}/opnfv-apex/os-nosdn-ovs-ha.yaml
91 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
92 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
93 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
94 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
95 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
96 %{_sysconfdir}/opnfv-apex/network_settings.yaml
97 %doc %{_docdir}/opnfv/LICENSE.rst
98 %doc %{_docdir}/opnfv/installation-instructions.html
99 %doc %{_docdir}/opnfv/release-notes.rst
100 %doc %{_docdir}/opnfv/release-notes.html
101 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
102 %doc %{_docdir}/opnfv/network_settings.yaml.example
103 %doc %{_docdir}/opnfv/inventory.yaml.example
104
105 %changelog
106 * Thu Jun 2 2016 Michael Chapman <michapma@redhat.com> - 3.0-7
107 - Add custom libvirt domain.xml.
108 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
109 - Add performance deployment file
110 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
111 - Fixes python3 dependency.
112 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
113 - Adds dependency for python34-setuptools
114 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
115 - Adds python network setting parsing lib.
116 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
117 - Adds python ip utility lib.
118 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
119 - adding opnfv-util
120 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
121 - Version update for Colorado
122 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
123 - adding dependencies initscripts net-tools iputils iproute iptables
124 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
125 - Adds example inventory file and nosdn scenario
126 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
127 - Updating the installation instructions
128 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
129 - Package Split