327df3bc2794f280109a5030e6fce9c8a42339df
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python34-setuptools
15
16 %description
17 Scripts for OPNFV deployment using RDO Manager
18 https://wiki.opnfv.org/apex
19
20 %prep
21 %setup -q
22
23 %build
24 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
25 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
26
27 %global __python %{__python3}
28
29 %install
30 mkdir -p %{buildroot}%{_bindir}/
31 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
32 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
33 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
34
35 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
36 install config/deploy/os-nosdn-nofeature-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
37 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
38 install config/deploy/os-nosdn-performance-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
39 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
40 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
41 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
42 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
43 install config/deploy/os-ocl-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
44 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
45
46 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
47 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
48 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
49 install lib/python/apex-python-utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
50 mkdir -p %{buildroot}%{python3_sitelib}/apex/
51 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
52 install lib/python/apex/deploy_env.py %{buildroot}%{python3_sitelib}/apex/
53 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
54 install lib/python/apex/network_environment.py %{buildroot}%{python3_sitelib}/apex/
55 install lib/python/apex/network_settings.py %{buildroot}%{python3_sitelib}/apex/
56 mkdir -p %{buildroot}%{python3_sitelib}/apex/common
57 install lib/python/apex/common/__init__.py %{buildroot}%{python3_sitelib}/apex/common/
58 install lib/python/apex/common/constants.py %{buildroot}%{python3_sitelib}/apex/common/
59 install lib/python/apex/common/utils.py %{buildroot}%{python3_sitelib}/apex/common/
60 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
61 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
62
63 mkdir -p %{buildroot}%{_docdir}/opnfv/
64 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
65 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
66 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
67 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
68 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
69 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
70 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
71
72 %files
73 %defattr(644, root, root, -)
74 %attr(755,root,root) %{_bindir}/opnfv-deploy
75 %attr(755,root,root) %{_bindir}/opnfv-clean
76 %attr(755,root,root) %{_bindir}/opnfv-util
77 %{_var}/opt/opnfv/lib/common-functions.sh
78 %{_var}/opt/opnfv/lib/utility-functions.sh
79 %{_var}/opt/opnfv/lib/python/
80 %{python3_sitelib}/apex/
81 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
82 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-noha.yaml
83 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
84 %{_sysconfdir}/opnfv-apex/os-nosdn-performance-ha.yaml
85 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
86 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
87 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
88 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
89 %{_sysconfdir}/opnfv-apex/os-ocl-nofeature-ha.yaml
90 %{_sysconfdir}/opnfv-apex/network_settings.yaml
91 %doc %{_docdir}/opnfv/LICENSE.rst
92 %doc %{_docdir}/opnfv/installation-instructions.html
93 %doc %{_docdir}/opnfv/release-notes.rst
94 %doc %{_docdir}/opnfv/release-notes.html
95 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
96 %doc %{_docdir}/opnfv/network_settings.yaml.example
97 %doc %{_docdir}/opnfv/inventory.yaml.example
98
99 %changelog
100 * Wed Jun 1 2016 Feng Pan <fpan@redhat.com> - 3.0-6
101 - Add performance deployment file
102 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
103 - Fixes python3 dependency.
104 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
105 - Adds dependency for python34-setuptools
106 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
107 - Adds python network setting parsing lib.
108 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
109 - Adds python ip utility lib.
110 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
111 - adding opnfv-util
112 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
113 - Version update for Colorado
114 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
115 - adding dependencies initscripts net-tools iputils iproute iptables
116 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
117 - Adds example inventory file and nosdn scenario
118 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
119 - Updating the installation instructions
120 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
121 - Package Split