0e44ebbc5a2b72d720a7b68004d2448d53703a2d
[apex.git] / build / opnfv-apex-common.spec
1 Name:           opnfv-apex-common
2 Version:        3.0
3 Release:        %{release}
4 Summary:        Scripts for OPNFV deployment using RDO Manager
5
6 Group:          System Environment
7 License:        Apache 2.0
8 URL:            https://gerrit.opnfv.org/gerrit/apex.git
9 Source0:        opnfv-apex-common.tar.gz
10
11 BuildArch:      noarch
12 BuildRequires:  python-docutils python34-devel
13 Requires:       openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
14 Requires:       initscripts net-tools iputils iproute iptables python34 python34-yaml python34-setuptools
15
16 %description
17 Scripts for OPNFV deployment using RDO Manager
18 https://wiki.opnfv.org/apex
19
20 %prep
21 %setup -q
22
23 %build
24 rst2html docs/installation-instructions/index.rst docs/installation-instructions.html
25 rst2html docs/release-notes/release-notes.rst docs/release-notes.html
26
27 %global __python %{__python3}
28
29 %install
30 mkdir -p %{buildroot}%{_bindir}/
31 install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
32 install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
33 install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
34
35 mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
36 install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
37 install config/deploy/os-odl_l2-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
38 install config/deploy/os-odl_l2-sfc-noha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
39 install config/deploy/os-odl_l3-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
40 install config/deploy/os-onos-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
41 install config/deploy/os-opencontrail-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
42 install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/network_settings.yaml
43
44 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/python/apex
45 install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
46 install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
47 install lib/python/apex-python-utils.py %{buildroot}%{_var}/opt/opnfv/lib/python/
48 mkdir -p %{buildroot}%{python3_sitelib}/apex/
49 install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
50 install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
51 install lib/python/apex/net_env.py %{buildroot}%{python3_sitelib}/apex/
52 mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
53 install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
54
55 mkdir -p %{buildroot}%{_docdir}/opnfv/
56 install LICENSE.rst %{buildroot}%{_docdir}/opnfv/
57 install docs/installation-instructions.html %{buildroot}%{_docdir}/opnfv/
58 install docs/release-notes/index.rst %{buildroot}%{_docdir}/opnfv/release-notes.rst
59 install docs/release-notes.html %{buildroot}%{_docdir}/opnfv/
60 install config/deploy/deploy_settings.yaml %{buildroot}%{_docdir}/opnfv/deploy_settings.yaml.example
61 install config/network/network_settings.yaml %{buildroot}%{_docdir}/opnfv/network_settings.yaml.example
62 install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/inventory.yaml.example
63
64 %files
65 %defattr(644, root, root, -)
66 %attr(755,root,root) %{_bindir}/opnfv-deploy
67 %attr(755,root,root) %{_bindir}/opnfv-clean
68 %attr(755,root,root) %{_bindir}/opnfv-util
69 %{_var}/opt/opnfv/lib/common-functions.sh
70 %{_var}/opt/opnfv/lib/utility-functions.sh
71 %{_var}/opt/opnfv/lib/python/
72 %{python3_sitelib}/apex/
73 %{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
74 %{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
75 %{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
76 %{_sysconfdir}/opnfv-apex/os-odl_l2-sfc-noha.yaml
77 %{_sysconfdir}/opnfv-apex/os-odl_l3-nofeature-ha.yaml
78 %{_sysconfdir}/opnfv-apex/os-onos-nofeature-ha.yaml
79 %{_sysconfdir}/opnfv-apex/os-opencontrail-nofeature-ha.yaml
80 %{_sysconfdir}/opnfv-apex/network_settings.yaml
81 %doc %{_docdir}/opnfv/LICENSE.rst
82 %doc %{_docdir}/opnfv/installation-instructions.html
83 %doc %{_docdir}/opnfv/release-notes.rst
84 %doc %{_docdir}/opnfv/release-notes.html
85 %doc %{_docdir}/opnfv/deploy_settings.yaml.example
86 %doc %{_docdir}/opnfv/network_settings.yaml.example
87 %doc %{_docdir}/opnfv/inventory.yaml.example
88
89 %changelog
90 * Sun May 15 2016 Feng Pan <fpan@redhat.com> - 3.0-5
91 - Fixes python3 dependency.
92 * Sun May 8 2016 Feng Pan <fpan@redhat.com> - 3.0-4
93 - Adds dependency for python34-setuptools
94 * Fri Apr 22 2016 Feng Pan <fpan@redhat.com> - 3.0-3
95 - Adds python network setting parsing lib.
96 * Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
97 - Adds python ip utility lib.
98 * Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
99 - adding opnfv-util
100 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0
101 - Version update for Colorado
102 * Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 2.2-0
103 - adding dependencies initscripts net-tools iputils iproute iptables
104 * Wed Jan 27 2016 Tim Rozet <trozet@redhat.com> - 2.1-4
105 - Adds example inventory file and nosdn scenario
106 * Wed Jan 20 2016 Dan Radez <dradez@redhat.com> - 2.1-3
107 - Updating the installation instructions
108 * Thu Jan 14 2016 Dan Radez <dradez@redhat.com> - 2.1-2
109 - Package Split