adding tackerclient to the build
[apex.git] / build / openstack-congress.spec
1 %define debug_package %{nil}
2
3 Name:           openstack-congress
4 Version:        2016.1
5 Release:        1%{?dist}
6 Summary:        OpenStack servicevm/device manager
7
8 Group:          Applications/Internet
9 License:        Apache 2.0
10 URL:            https://wiki.openstack.org/wiki/Congress/Installation
11 Source0:        openstack-congress.tar.gz
12
13 BuildArch:      noarch
14 BuildRequires:  python-setuptools python2-oslo-config python2-debtcollector
15 #Requires:      pbr>=0.8 Paste PasteDeploy>=1.5.0 Routes>=1.12.3!=2.0 anyjson>=0.3.3 argparse
16 #Requires:      Babel>=1.3 eventlet>=0.16.1!=0.17.0 greenlet>=0.3.2 httplib2>=0.7.5 requests>=2.2.0!=2.4.0
17 #Requires:      iso8601>=0.1.9 kombu>=2.5.0 netaddr>=0.7.12 SQLAlchemy<1.1.0>=0.9.7
18 #Requires:      WebOb>=1.2.3 python-heatclient>=0.3.0 python-keystoneclient>=1.1.0 alembic>=0.7.2 six>=1.9.0
19 #Requires:      stevedore>=1.5.0 http oslo.config>=1.11.0 oslo.messaging!=1.17.0!=1.17.1>=1.16.0 oslo.rootwrap>=2.0.0 python-novaclient>=2.22.0
20
21 %description
22 OpenStack policy manager
23
24 %prep
25 #git archive --format=tar.gz --prefix=openstack-congress-%{version}/ HEAD > openstack-congress.tar.gz
26
27 %setup -q
28
29
30 %build
31 #rm requirements.txt
32 #/usr/bin/python setup.py build
33
34
35 %install
36 /usr/bin/python setup.py install --prefix=%{buildroot} --install-lib=%{buildroot}/usr/lib/python2.7/site-packages
37
38 install -d -m 755 %{buildroot}/var/log/congress/
39 install -d -m 755 %{buildroot}/etc/congress/snapshot/
40
41 install etc/api-paste.ini %{buildroot}/etc/congress/api-paste.ini
42 install etc/policy.json %{buildroot}/etc/congress/policy.json
43 tox -egenconfig
44 install etc/congress.conf.sample %{buildroot}/etc/congress/congress.conf
45
46 install -p -D -m 644 openstack-congress.service %{buildroot}%{_unitdir}/openstack-congress.service
47 install -d -m 755 %{buildroot}%{_sharedstatedir}/congress
48
49 %pre
50 getent group congress >/dev/null || groupadd -r congress
51 if ! getent passwd congress >/dev/null; then
52   useradd -r -g congress -G congress,nobody -d %{_sharedstatedir}/congress -s /sbin/nologin -c "OpenStack Congress Daemon" congress
53 fi
54 exit 0
55
56 %post
57 %systemd_post openstack-congress
58
59 %preun
60 %systemd_preun openstack-congress
61
62 %postun
63 %systemd_postun_with_restart openstack-congress
64
65 %files
66
67 %config /etc/congress/congress.conf
68 /etc/congress/policy.json
69 /etc/congress/api-paste.ini
70 /bin/congress-server
71 /bin/congress-db-manage
72 %{_unitdir}/openstack-congress.service
73 /usr/lib/python2.7/site-packages/congress/*
74 /usr/lib/python2.7/site-packages/congress-*
75 /usr/lib/python2.7/site-packages/congress_tempest_tests/*
76 /usr/lib/python2.7/site-packages/antlr3runtime/*
77 %dir %attr(0750, congress, root) %{_localstatedir}/log/congress
78
79 %changelog
80